ICM 7.2.4 CTI Server failover

Unanswered Question
Aug 13th, 2008
User Badges:

The following ICM 7.2.4 setup:

CCM PG with CTI Server A and B side geographically separated, with 2 separate networks for visible and private LAN.

Failover using ICM service control stop/start, killing dos boxes of icm processes all work ok. However unplugging the visible network cable on e.g. A side results in PG pim and jtapigw processes to become active on the B side, but NOT the CTI server process on the B side.

ICM setup on A and B side with settings like

PG private: xxxpg03ap, xxxpg03bp

CG private: xxxpg03ap, xxxpg03bp

CG visible: xxxpg03a, xxxpg03b


which result in a CG registry key with

CGPrivateInterfaceA/B: xxxpg03ap, xxxpg03bp

CGPublicInterfaceA/B: xxxpg03a, xxxpg03b

and

PGPrivateInterfaceA/B: xxxpg03ap, xxxpg03bp

PGPublicInterfaceA/B: xxxpg03ap !!!, xxxpg03bp !!!

and the same on the B side


On another platform with similar setup (but v7.1.5) the values are

on the A side

PGPublicInterfaceA/B: xxxpg03a, xxxpg03a !!!


and on the B side

PGPublicInterfaceA/B: xxxpg03b !!!, xxxpg03b


Can somebody explain to me what the values means and what they should be ?


I tried about every combination of private and visible ip# in the registry, but it did not solve the issue.

Network settings are according to Cisco ICM windows staging spec.

Any ideas ?

Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Well, the first ones you marked with !! appear to be wrong. Surely the public interface has to be:


A side:

(A) xxxpg03a and (B) xxxpg03b.


B side:

(A) xxxpg03a and (B) xxxpg03b.



The 7.1.5 looks wrong too.


A side:

PGPublicInterfaceA/B: xxxpg03a, xxxpg03b


B side:

PGPublicInterfaceA/B: xxxpg03a, xxxpg03b


Regards,

Geoff




peter.straatman... Wed, 08/13/2008 - 06:16
User Badges:

Hi Geoff

The thing is that these (wrong) values are set by the icm setup !

I modified the registry into what I thought are the correct settings but it did not make a difference.

Regards

peter.straatman... Wed, 08/13/2008 - 09:39
User Badges:

yes !!!

I ran ICM setup several times, always the same result.

I ran setup with garbage then with correct values, deleted registry, deinstalled SR4, reinstalled SR4, etc.

Very weird.

But even with the correct values put in the registry manually, the failover fails when unplugging network cables. Failover with process stop/start is ok.


Actions

This Discussion