Not able to Login to CCM admin for 6.1.2 due to "database comm error"

Unanswered Question
Aug 13th, 2008

Hi ,

My name is Rohan Sahi.

I am trying to install a CCM 6.1.2 on 7825H3 server.

The installation is complete but I have trouble logging into the OS administration account.Whenever I try to login to Cisco Unicfied CM Administration window using the system admin id ( CCMADMIN ) and password ([email protected]) I am getting the following error message.

"Database Communication Error"

On the other hand I am able to login to the IPT admin user for OS adminstration using id IPTAdmin and password [email protected] After that I am also able to access the CM admin window.

I would like to poin out that there is no issue with the password or login id because I have used the login id and password on the CLI.

Please let me kno what could be the ccause of this.

Is it a bug, or incomapatibilty or installation disk problem and revert back as soon as possible.

Thanks And Regards,

Rohan Sahi.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Michael Owuor Wed, 08/13/2008 - 06:18

Hi Rohan,

Welcome to NetPro. We hope you find this forum useful, and look forward to you being a contributor. If you want to get an idea of the expectations of quality that we have of contributors, just search for 'Rob Huffman' :-)

A couple of points to note here:

1. The user ID and password that you use to log into the CLI with is not the same one you use to log into the CM Administration window. So successfully logging into the CLI does not mean those credentials should work on the CM Administration page.

2. The user ID and password that you use to log into the OS administration page is not the same one you use to log into the CM administration page. It is, however, the same one you use to log into the CLI.

3. After logging into the OS Administration pages, you only have access to the OS specific pages. If you try to navigate to the CM Administration pages, you will be prompted to log in again using the credentials specific to the CM Administration pages.

So the the most probable cause of the problem based on evidence so far is login ID and password for the CM Administration page. Do you agree?

The good news is that since you have access to the CLI, you can reset the CM Administration name and password. To change the CM Administrator name or password, use the following commands from the CLI:

utils reset_ui_administrator_password

utils reset_ui_administrator_name

Try this and let us know the results.

Regards,

Michael.

rohan_sahi Wed, 08/13/2008 - 07:00

Hi Micheal,

Thanks for your reply.

After you told me about the similarity between the passwords, I realised that I have interchanged the patform and the OS admin login and password.

The credentials that I was using were opposit i.e. where I should use the credntials of OS admin I was using the CM admin login and password.

That is why I thought that I was entering the CLI with CM admin password. :)

Please let me know

Is it mandatory that the login id for OS admin should always be IPT admin and for CM admin should always be CCMAdministrator?

Could we change the IPT admin password also?

If its mandatory should I go for a reinstallation?

Thanks And Regards

Rohan

Michael Owuor Wed, 08/13/2008 - 07:22

Hi Rohan,

Thanks for the update. To answer your new questions:

You cannot change the OS Admin/CLI account name that you created during installation. You can however:

a. Change the password associated with that account using the 'set password admin' command from the CLI.

b. Create additional OS Admin accounts using the 'set account' CLI command.

If you absolutely have to change the name of the OS Admin/CLI account, you would have to reinstall.

Does this answer your question?

Regards,

Michael.

rohan_sahi Mon, 08/18/2008 - 02:40

Hi,

Thanks for the support.The issue was same as I pointed out (wrong login id and password).

I am facing another issue.I have to perform teaming of the NIC cards on the servers.I have performed teaming on the Unity server using Window2003 as platform but not on the Call manager.Since it is Linux I dont know how to achieve that.

Please find the detials and let me know if the 2 NIC ports can be teamed or not.

Server - MCS-7825 H3

CCM version - 6.2.1

There is another server with Unity connection of the same model.The CCM and the Unity connection are on separate boxes.

In case if teaming is not possible , please let me know how can we achieve Device level redundancy for the Core switch.

Let me explain the scenario.There are two core switch acting as HSRP.I have to connect one NIC port to one switch and other NIC port to another, so that a faliure in one swicth will not lead to complete jamming of network.

Please let me know a way of acieving this if teaming cannot be done on above mentioned servers.

Thanks And Reagdrs

Rohan Sahi

Steellllllllll0 Mon, 08/18/2008 - 03:26

Hi Guys,

I am having a similar problem logging into the ccmadmin. I have tried the utils commands in the previous post but it did not work.

We tried changing the ip address of cucm initially and then done a hard reboot and since it has come up we have not been able to login into ccmadmin again...any ideas ??

Actions

This Discussion