Agents Stuck in WORK State

Unanswered Question
Aug 13th, 2008
User Badges:

All of my agents are getting stuck in a WORK state. This happened after performing a restart of the UCCX server. I tried restarting the queue and applications, but this didn't help. I did not perform a configuration change or update to the system.


This is what is happening:


1. Agents handle a call then hangup.

2. The agents are put into a WORK status by the system.

3. They stay in WORK status until they manually put themselves back into a READY state.

4. After manually putting themselves in READY they can receive calls again, but will get stuck in WORK status as soon as they hang up.


Normally there is a 15 second period that agents are in WORK status. Afterwords they are automatically put back into a READY status.


I am running IPCC Express Enhanced 4.0(5)_Build042

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
zebranutz80 Wed, 08/20/2008 - 06:13
User Badges:

Thanks for replying. I opened a TAC case and found that a Service Release needed to be installed on our Contact Center. There is a documented bug regarding the Wrapup Timer Not Working. Please see case notes below:



On the Resource configuration, for each agent check that Automatic Available is set to Enabled.

Next, on the CSQ, check that Wrapup Time is enabled, and that the seconds field is set.

The defect you are most likely hitting is CSCsh43145 - Wrapup Timer Not Working. This is fixed in the SR1 patch for 4.0(5). I recommend the SR2 patch, since these are cumulative.

The SR2 patch is available for download on Cisco.com here-

http://tools.cisco.com/support/downloads/go/Redirect.x?mdfid=270569179

The steps to apply the SR patch are found in the CRS 4.0(5) installation guide, in the section "Patching Cisco CRS"

http://cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_4_0/installation/for_crs/405/crs405ig.pdf

Abdulbaseer Mohammed Fri, 08/29/2008 - 23:05
User Badges:
  • Silver, 250 points or more

Did the SR2 patch solved it?


if not I think your problem is some settings are changed in CSD you may want to see the wrap up time etc.


good luck.

Baseer.

Actions

This Discussion