Trouble with the Upload Document step

Unanswered Question
Aug 13th, 2008

Hello. Runnig IPCC 403. We are attempting to write a script that will read/write a file stored in the repository. We would like to use the repository and not the disk since we have an HA config.

In the script that writes the file, we are able to write to disk using the Write Document step but we are not able to upload this document or the same document located in memory to the repository.

We are attempting to use the Get user and Authenticate User Password steps prior to the Upload Document step. The auth steps completes successfully as far as we can tell. The Upload Document step does not result in script errors but completes unsuccessfully when running interactive debug. No files are created in the respository.

The script is attached. Any inout would be appreciated.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
edguidry Fri, 08/15/2008 - 11:06

We added the Create File Document step to our script and we were able to upload a file to the repository.

sanjeev.thallik... Fri, 08/15/2008 - 12:16

No. Create File Document is not your answer because it will not load it to the repository.

The answer to your issue is you need to user ipccuser in your authenticate step and not "ipccadmin. The Authenticate User step requires a variable of type "user". Try that. i had the same issue today and it worked after i used the varible of type "user" instead of the string that has the username.

abcronin Mon, 03/09/2009 - 21:42

Hi Guys

I have the same issue as above I have the correct steps and variables set but it still fails on the document upload.

I am trying to upload a simple xml file on UCCX 5.0(2) and have added a create file document set before the upload and an authenticate user step but still no joy. Driving me crazy!

Any help would be appreciated



abcronin Wed, 03/11/2009 - 18:27

just an update, I got this to work by getting the order right in the script. Had to have a get user step to populate a 'User' variable then authenticate that user, in the success branch have the upload doc step..

this is in bug CSCsg65186 btw


James Hawkins Tue, 06/30/2009 - 14:31


Thank you very much for posting the solution.

Is it just me or is this whole repository thing a nightmare!


This Discussion