IPCCX6.0 HA installation with 2 CRS servers

Unanswered Question
Aug 14th, 2008
User Badges:

Hi,

Can anybody tell me what special has to be configured for HA for redundancy:


for e.g. when installaling CRS1 server, we need to give ip of CCM PUB as LDAP.

How about the LDAP details while installing CRS2? will it be CCM PUB or SUB for LDAP?

2)How about the CRS software installation and setup on CRS2, what do we need to configure differently from CRS1 during the installation?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chad Stachowicz Thu, 08/14/2008 - 17:51
User Badges:
  • Silver, 250 points or more

Basically everything is synched automatically between the servers for you. When you start, do initial setup on the UCCX PUB choose First Node in Cluster. go through it provide whichever ccm detials you want. On the UCCX SUB Choose add to cluster etc, and go through it! Now they will be syched. (Also remember when you install it for HA don't forget SQL Full. Order is..


1.) OS Disc.

2.) UCCX Disc

3.) SQL Disc

on both servers. )


After this configure EVERYTHING on the primary. You only need to upload licenses to the primary, prompts scripts and everything to the primary. Configure CTI Ports etc, they will all be automatically created on the HA Server and registered etc..


Occasionally in an HA install after initial setup is done, when some reboots has been done, and you go to do a change on the primary (say a skill group). you get a 'cannot update UCCX Database Error'... In control Center make sure that the Primary is always Master server (specified with a blue M). If its not and for some reason the Subscriber is Master server. Restart the Node Manager outside of production on the subscriber and Primary will retain Master and everything good to go. NEVER change anything on the sub :). Lastly I would like to say in my experience, HA is a bit touchy. Its like the girlfriend that always cries over stupid things. So watch out for a crier ;(



HTH, please rate useful posts..


Chad


adham_tahoun Tue, 09/02/2008 - 12:53
User Badges:

Hi Chad


It seems that you know what I need :) .. so kindly I need your help.


Without going in details about what happened with me, I am going to fresh installation, as it seems the HA didn't work,


So, as you mentioned the sequence I should work with is

1.Pub OS Disc

2.Pub UCCX Disc

3.Sub OS Disc

4.Sub UCCX Disc

5.Pub SQL Disc

6.Sub SQL Disc

7.Pub Configuration: 1st node

8.Sub Configuration: Add to Cluster


something else, If I am licensed for 40 IVR, 20 EIM and 20 WIM ports, why does it create 80 cti ports, is it the total of the licensed units or the double of the 40 ?


Thanks in advance


Adham

Actions

This Discussion