Incoming Calls

Unanswered Question
Aug 14th, 2008

Hi Guys,

I have a problem on a new setup with incoming calls not ringing through to the phone.My dial peers are being matched and i`m using translation patterns to convert from 6-5 digits.Gateway is H323.So is there a way of checking where the breakdown is occuring on ccm 6.0 ?

Also does it matter if the phones and the ccm are on different vlans.The phones are registered with the ccm...thanks!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Marwan ALshawi Thu, 08/14/2008 - 21:40

if they are in deffrent vlans and can communicat its ok

and about the translation pattren

if u only makthe 6 digits or 7 to 5

u can avoid this and let the H323 forward the whole number to the CUCM

and on the CUCM on the gateway seetings there is option called significant digits

chose 4, 5 what ever number u want to be forwarded

for example if u use only last for digit on the internal ip phon

chose 4

and make sure u forward the hole number in this case

Steellllllllll0 Fri, 08/15/2008 - 00:32

Hi Guys,

Part of the problem is also when i dial in i get two calls showing up on the debug q931 from my no at the same time :

Calling Party Number i = 0x2183, '7895606931'

Plan:ISDN, Type:National

Called Party Number i = 0x81, '260'

Calling Party Number i = 0x2183, '7895606931'

Plan:ISDN, Type:National

Called Party Number i = 0x81, '579260'

I have tried matching both patterns on the dial peers as well as the translation patterns.

Steellllllllll0 Fri, 08/15/2008 - 01:42

Hi,

Here is a scaled down version of the voice config :

aaa session-id common

network-clock-participate wic 1

network-clock-select 1 E1 0/1/0

ip cef

!

multilink bundle-name authenticated

!

isdn switch-type primary-net5

!

voice-card 0

no dspfarm

dsp services dspfarm

!

voice call send-alert

voice call carrier capacity active

voice rtp send-recv

!

voice class codec 1000

codec preference 1 g711alaw

!

voice class h323 1

h225 timeout tcp establish 2

call start fast

voice translation-rule 1

rule 1 /^2/ /792/

!

voice translation-profile Incoming

translate calling 1

!

username

username

!

!

controller E1 0/1/0

pri-group timeslots 1-18

!

controller E1 0/1/1

interface GigabitEthernet0/0

no ip address

duplex auto

speed auto

!

interface GigabitEthernet0/0.200

encapsulation dot1Q 200

ip address 10.X.X.X 255.255.255.192

h323-gateway voip interface

h323-gateway voip bind srcaddr 10.X.X.X

!

interface GigabitEthernet0/0.500

encapsulation dot1Q 500

ip address 10.Y.Y.Y 255.255.255.192

!

interface GigabitEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

interface FastEthernet0/0/0

!

interface FastEthernet0/0/1

!

interface FastEthernet0/0/2

!

interface FastEthernet0/0/3

!

interface Serial0/1/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

interface Vlan1

no ip address

shutdown

!

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0.500

!

control-plane

!

voice-port 0/1/0:15

cptone GB

!

dial-peer voice 50 voip

description **h323 incoming calls**

destination-pattern 579...

progress_ind setup enable 3

voice-class h323 1

session target ipv4:10.c.c.m

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax rate disable

no vad

!

dial-peer voice 40 pots

description **Incoming Pstn Calls**

destination-pattern 5792..

direct-inward-dial

port 0/1/0:15

!

dial-peer voice 51 voip

description **h323 incoming calls**

translation-profile incoming Incoming

destination-pattern 2..

progress_ind setup enable 3

voice-class h323 1

session target ipv4:10.3.110.140

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax rate disable

no vad

!

dial-peer voice 41 pots

description **Incoming calls**

translation-profile incoming Incoming

destination-pattern 2..

direct-inward-dial

port 0/1/0:15

Thanks!!

Marwan ALshawi Fri, 08/15/2008 - 02:09

dial-peer voice 40 pots

description **Incoming Pstn Calls**

destination-pattern 5792..

incoming called-number .

direct-inward-dial

port 0/1/0:15

forward digit all

after each pots dial peer u need eaither forward digit all

or forward digit [number of digits]

and ur thranslation profile is translating the calling number not called

is that what u eant?

voice translation-profile Incoming

translate calling 1

can u just send what u want to be forward [numbers to ccm] and send to pstn and what numbers u recieve and wanna send exactly to fix those dialperrs

thanks u

Steellllllllll0 Fri, 08/15/2008 - 02:24

Hi,

There are no incoming calls at all coming through to my DN`s i have checked the class of control/gateways etc translation patterns.

As in my previous posting if i dial one of my numbers from my mobile i get two calls coming through on the isdn at the same time both with my cli but presenting different amounts of digits.I am just thinking this is part of the problem.If i debug the dial peers they are being matched tho:

Aug 15 08:48:50: ISDN Se0/1/0:15 Q931: RX <- SETUP pd = 8 callref = 0x0001

Sending Complete

Bearer Capability i = 0x9090A3

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98381

Exclusive, Channel 1

Calling Party Number i = 0x2183, '7589526412'

Plan:ISDN, Type:National

Called Party Number i = 0x81, '579260'

Plan:ISDN, Type:Unknown

Aug 15 08:48:50: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x2

0x1, Calling num 7589526412

Aug 15 08:48:50: ISDN Se0/1/0:15 Q931: Applying typeplan for sw-type 0x12 is 0x0

0x1, Called num 260

Aug 15 08:48:50: ISDN Se0/1/0:15 Q931: TX -> CALL_PROC pd = 8 callref = 0x8001

Channel ID i = 0xA98381

Exclusive, Channel 1

Aug 15 08:48:50: ISDN Se0/1/0:15 Q931: TX -> SETUP pd = 8 callref = 0x00A0

Sending Complete

Bearer Capability i = 0x9090A3

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98392

Exclusive, Channel 18

Calling Party Number i = 0x2183, '7589526412'

Plan:ISDN, Type:National

Called Party Number i = 0x81, '260'

Plan:ISDN, Type:Unknown

Aug 15 08:48:50: ISDN Se0/1/0:15 Q931: RX <- CALL_PROC pd = 8 callref = 0x80A0

Channel ID i = 0xA98392

Exclusive, Channel 18

Aug 15 08:48:50: ISDN Se0/1/0:15 Q931: RX <- PROGRESS pd = 8 callref = 0x80A0

Cause i = 0x8A96 - Number changed

Progress Ind i = 0x8488 - In-band info or appropriate now available

Aug 15 08:48:50: ISDN Se0/1/0:15 Q931: TX -> ALERTING pd = 8 callref = 0x8001

Progress Ind i = 0x8488 - In-band info or appropriate now available

Aug 15 08:48:50: ISDN Se0/1/0:15 Q931: RX <- DISCONNECT pd = 8 callref = 0x80A0

I have checked everything i can possibly think of and cannot find anything this is the only thing which is not right.

btmulgrew Fri, 08/15/2008 - 02:56

Hi - I think your inbound and outbound calls are being matched by your pots dial peer.

As mentioned in previous post change your translation profile to called. Also remove translation profile from voip dial peer and apply to voice port as incoming.

Marwan ALshawi Fri, 08/15/2008 - 03:05

no voice translation-profile Incoming

voice translation-profile Incoming

translate called 1

dial-peer voice 50 voip

description **h323 incoming calls**

destination-pattern 579...

progress_ind setup enable 3

voice-class h323 1

session target ipv4:10.c.c.m

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax rate disable

no vad

dial-peer voice 40 pots

description **Incoming Pstn Calls**

destination-pattern 5792..

incoming called-number 5792..

direct-inward-dial

port 0/1/0:15

forward digit all

dial-peer voice 41 pots

description **outgoing calls**

translation-profile outgoing Incoming

destination-pattern 2..

direct-inward-dial

port 0/1/0:15

forward digit all

try to keep only the above dial peers with the change i have made to u

and see it

Steellllllllll0 Fri, 08/15/2008 - 03:48

Hi,

Thats exactly as i have it at the moment but still calls are ringing but not on the handset.

Is there a way on ccm 6.0 to actually see if the calls are reaching the ccm ??

Marwan ALshawi Fri, 08/15/2008 - 03:59

first how many digits r u using in ccm?

and how many digit u send to ccm?

have u checked the option significante digits on the gateway settings?

u have to chose how many digit u want ur ccm take from the gateway

let me know about these digits

if u send me ur dial paln will give u the exact config if u want

send want is the numbers u use in ur ccm

what numbers u recieve and want to send to and from the pstn

Steellllllllll0 Fri, 08/15/2008 - 04:44

Hi,

The carrier is presenting 6 digits (579XXX) and my extension numbers are the last five digits (79XXX).Dial peers are setup exactly as u outlined previously.I have translation pattern translating the 6 digits to 5digits and Sig Digits on the gateway set to 6.Even with this set to 5 and no translation pattern calls still do not ring through.I dont have anything listed under my dial plan installer on ccm....is this why ???

Marwan ALshawi Fri, 08/15/2008 - 05:29

first save all the config u have to external file

then remove the translation profile u have and all the dial peers and use the following seetings:

voice translation-rule 1

rule 1 /5\(79...\)/ /\1/

voice trnaslation-profile progile1

translate called 1

dial-peer voice 9 pots

description "incoming-outgoing pots"

translation-profile incoming profile1

incoming called-number 579...

destination-pattren 579...

direct-inward-dail

port 0/1/0:15

forward-digit all

dial-peer voice 99 voip

destination-pattren 79...

session target ipv4:[ur ccm ip]

on the CCM make the significant digit either 5 or all because we have used translation on the gateway

also make sure u have registered phones with numbers in the range of 79000 - 7999

and also make sure u have seted up the CSS and partitions corectly on the phones and the gateway setting on the CCM

Steellllllllll0 Fri, 08/15/2008 - 06:16

voice translation-rule 1

rule 1 /5\(79...\)/ /\1/

voice translation-profile incoming

translate called 1

dial-peer voice 50 voip

description **h323 incoming calls**

destination-pattern 79...

progress_ind setup enable 3

voice-class h323 1

session target ipv4:10.c.c.m

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax rate disable

no vad

dial-peer voice 40 pots

description **Incoming Pstn Calls**

translation-profile incoming incoming

destination-pattern 579...

incoming called-number 579...

direct-inward-dial

port 0/1/0:15

forward-digits all

In CCm,gateway css set to Unrestricted and sig digits set to all(tried 5)

DN & phone in same css as gateway

Still it will not work !!

Marwan ALshawi Fri, 08/15/2008 - 18:38

phone not inmportant to be in the same CSS as the gateway

but the should be in a partition included in the gateway CSS

this is for incoming calls

the revers of the idea for outgoing calls

make sure that the gateway CSS includ the phones partetion

good luck

a.gooding Fri, 08/15/2008 - 22:10

just a small input

id do the following csim start and the extension number - at least if it works then it is going from the rtr to the ccm to the phone basically.

then debug voice ccapi inout and see whats going on there with the DP and what digits are coming out.

Actions

This Discussion