urgent help needed in PBR

Unanswered Question
Aug 15th, 2008

Dear all

i have 2 offices, from office A i have 2 point to point leased lines(128kbps each)

connecting to office B.

office A ------------------- Office B

192.168.1.0/24 ------------------ 192.168.3.0/24

i have not bundled the 2 serial lines i had put 2 routing entries in office A router

ip route 192.168.3.0 255.255.255.0 Serial0/0/0

ip route 192.168.3.0 255.255.255.0 Serial0/0/1

from office B router also i have the proper routing entries and it is working fine.

now my requirement is i have got an internet leased line and i've 6 public ip addresses as well, from office A i need to publish one server i tried configuring

policy based routing on the same router but it is not working can anybody help me in this issue.

i will post the configuration file please have a look into it.i will rate all the suggestions

thanks & regards

Binoy

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.5 (2 ratings)
Loading.
tdrais Fri, 08/15/2008 - 02:49

First try to set the nexthop to a ip address on the far end of serials like 85.154.246.181. Many times setting the nexthop to the interface has a issue.

From you configuration your policy routing if it worked would send all the traffic from fa 0/0 to router b over serial 0/0/0 and all traffic from fa 0/1 to the internet via serial 0/1/0. This is assuming there are no other subnets behind these ports.

If that is what you are tring to accomplish it may just be the nexthop thing.

binoyjosephstanly Fri, 08/15/2008 - 02:57

hi frnd thanks for your reply

from the router im able to ping the next hop 181 and able to reach my public dns as well but when connect my laptop directly to the fa0/1 and try to browse its not happening and if i try to ping external dns its not working. from as i told u from the router im able to ping the external dns.

is there something wrong with my config

tdrais Fri, 08/15/2008 - 03:06

See if you can ping internet locations from the router using a extended ping with a source of 85.154.246.145.

If this does not work then the ISP is not routing your block of addresses to you correctly. If it does try to remove the policy route from the fa 0/1 and try your PC again.

Without the policy route it should now use the default route like the router did.

lee.reade Fri, 08/15/2008 - 03:08

Hi,

Im not sure why you require PBR here, why cant u just route traffic?

Does your laptop have its default gateway set to 85.154.246.145?

Has your ISP gave you two IP ranges? Could be that they are not routing back to your 85.154.246.144 network.

HTH

LR

binoyjosephstanly Fri, 08/15/2008 - 03:45

see in this case there are 2 routing entries required rt one is to my office B and one is to internet can u suggest me the best practise

binoyjosephstanly Fri, 08/15/2008 - 03:53

on my serial .182 is there and im routing to 181 which is /30 network.

and from my .144 network 145 ive assigned to fa0/1 and tried. fa0/0 is a private range bcoz it is routing to my office B using 2 point to point leased lines.

so packets to my office b should go only to the serials with private range ip's fa0/1 i will be connecting to a firewall so that my servers traffic go to internet thats the idea behind the pbr.

Actions

This Discussion