QOS on 1861 and VG224 FXS Interfaces

Answered Question
Aug 16th, 2008

I will be connecting a couple of 1861's...and also some VG224's to 2821 and 3825 routers. If i am plugging analog phones into the FXS ports on the 1861's and VG224's do they automatically mark the packets coming from the FXS interfaces as voice packets (EF) or do i need to do this manually?...if so i am not sure how i would because the interfaces are voice ports which i havent assigned ip addresses to...I would imagine that if i was using an IP phone instead of analogue i would be able to set the QOS on the phone itself so as to get end to end packet marking, but how does this happen with an analogue phone that has no QOS or IP capabilities?


Thanks and regards,



Correct Answer by Marwan ALshawi about 8 years 6 months ago

it sounds i cklicked twice on the post :)


anyway


just one note

the above policy should be apllied on the interface of the switch or router that connected to the VG


and add the following line to the


ip access-list extended call-signaling

permit tcp any any range 2000 2002


and good luck

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Marwan ALshawi Sat, 08/16/2008 - 02:18

if u have voip dial peer point to ur CCM then u can make the marking through this dial peer


for example


dial-peer voice 1 voip

distination-patren [ccm ip]

codec g711ulaw

no vad

ip qos dscp ef media

ip qos dscp cs3 signaling


however what i sugest u is because u have the VG will be on one vlan which is the vlan that belongs to voice lets say vlan 20


so just creat an ACL that match all traffic coming fron that vlan for example the range will be like 10.1.1.0/24

so make somthing not exactly but similer to :


ip access-list extended call-signaling

permit tcp any any range 1719 1720

permit tcp any any range 2428


ip access-list extended VVLAN

permit udp 10.1.1.0 0.0.0.255 any range 16384 32767


class-map match-all VVLAN-VOICE

match access-group VVLAN


class VVLAN-CALL-SIGNALING

match access-group call-signaling


policy-map VG-marking

class VVLAN-VOICE

set ip dscp 46


class VVLAN-CALL-SIGNALING

set ip dscp 24


here the interface gos from the VG to the lan


interface [port number]

service-policy input VG-marking


u can chose from the above to ways which one suit u


good luck


please, if helpful Rate

Marwan ALshawi Sat, 08/16/2008 - 02:18

if u have voip dial peer point to ur CCM then u can make the marking through this dial peer


for example


dial-peer voice 1 voip

distination-patren [ccm ip]

codec g711ulaw

no vad

ip qos dscp ef media

ip qos dscp cs3 signaling


however what i sugest u is because u have the VG will be on one vlan which is the vlan that belongs to voice lets say vlan 20


so just creat an ACL that match all traffic coming fron that vlan for example the range will be like 10.1.1.0/24

so make somthing not exactly but similer to :


ip access-list extended call-signaling

permit tcp any any range 1719 1720

permit tcp any any range 2428


ip access-list extended VVLAN

permit udp 10.1.1.0 0.0.0.255 any range 16384 32767


class-map match-all VVLAN-VOICE

match access-group VVLAN


class VVLAN-CALL-SIGNALING

match access-group call-signaling


policy-map VG-marking

class VVLAN-VOICE

set ip dscp 46


class VVLAN-CALL-SIGNALING

set ip dscp 24


here the interface gos from the VG to the lan


interface [port number]

service-policy input VG-marking


u can chose from the above to ways which one suit u


good luck


please, if helpful Rate

Marwan ALshawi Sat, 08/16/2008 - 02:18

if u have voip dial peer point to ur CCM then u can make the marking through this dial peer


for example


dial-peer voice 1 voip

distination-patren [ccm ip]

codec g711ulaw

no vad

ip qos dscp ef media

ip qos dscp cs3 signaling


however what i sugest u is because u have the VG will be on one vlan which is the vlan that belongs to voice lets say vlan 20


so just creat an ACL that match all traffic coming fron that vlan for example the range will be like 10.1.1.0/24

so make somthing not exactly but similer to :


ip access-list extended call-signaling

permit tcp any any range 1719 1720

permit tcp any any range 2428


ip access-list extended VVLAN

permit udp 10.1.1.0 0.0.0.255 any range 16384 32767


class-map match-all VVLAN-VOICE

match access-group VVLAN


class VVLAN-CALL-SIGNALING

match access-group call-signaling


policy-map VG-marking

class VVLAN-VOICE

set ip dscp 46


class VVLAN-CALL-SIGNALING

set ip dscp 24


here the interface gos from the VG to the lan


interface [port number]

service-policy input VG-marking


u can chose from the above to ways which one suit u


good luck


please, if helpful Rate

Correct Answer
Marwan ALshawi Sat, 08/16/2008 - 03:54

it sounds i cklicked twice on the post :)


anyway


just one note

the above policy should be apllied on the interface of the switch or router that connected to the VG


and add the following line to the


ip access-list extended call-signaling

permit tcp any any range 2000 2002


and good luck

Actions

This Discussion