ASA Will not boot

Unanswered Question
Aug 17th, 2008

My ASA reloaded and now gets stuck at Loading Boot Loader... when booting. i tftp'd an image to the asa in rommon, but while its booting i see that it failed to mount disk0: (the flash). Once it is completely booted a dir disk0: show that disk0: has 0 bytes available 0 bytes total. any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 1 (1 ratings)
Farrukh Haroon Sun, 08/17/2008 - 21:43

Try formatting the flash drive.

For testing try loading a smaller image then boot into ASA, then try to upgrade to your desired version.



oabduo983 Sun, 08/17/2008 - 22:39

Where in the sequence does it stop? can you paste the CLI messages you are getting?

danwharam Sat, 08/23/2008 - 05:44

I had a asa 5520 that had a corrupted flash. So I formated the flash, and reloaded. The device came up in Rommon. In rommon, I set the address, server, gateway, image and port. When I run tftpdnld, I can execute the image and escape out of rommon to the ciscoasa prompt, the pwd is blank, so now i am in ciscoasa# enable mode.

Like, you I see the mount errors and the disk space on my flash is 0 bytes.

At this time, I format the flash again. Now the flash looks good. Now, I need to prepare the device to connect to my tftpserver to download the image (asa and asdm) and perhaps a backup of the config to the device. Once that is done, now, I can re-download the image to flash and write mem without any issues.

I have seen this on 5510 and 5520. Where I have to format the flash that second time.

Hope this helps

ryancolson Sat, 08/30/2008 - 16:56

I have a question that goes along with this. My friend had a case where his flash did something similar. He did not reformat it, but was wondering if there is any way to recover the activation key, as he had not taken note of it before?

estadlercisco Sun, 08/31/2008 - 11:15

what activation key? the 3DES/AES key can be gotten at anytime, through the website all you need is a serial number. When this happened to me i just searched through old emails and found it, they should have sent him an email with the activation key in it...

ryancolson Sun, 08/31/2008 - 11:59

the device was supposed to come wtih security plus. your telling me if he just takes the serial #, pops it into the free AES/DES upgrade, he would receive the key for full sec plus?

estadlercisco Sun, 08/31/2008 - 11:16

thanks for your help. I ended up purchasing a flash card and replaced the one i was having problems with. I even put the card in a PCMCIA flash card reader formatted it and copied the image over from my laptop. this still resulted in the same problem.

manjesin Sat, 08/30/2008 - 18:17


Once you are able to uploaded the image from rommon mode and able to get to the ciscoasa> then get to the configuration prompt

ciscoasa(config)# and configure the interface on which tftp server is connected

then upload the same IOS image again with "copy tftp flash" command. This time image will uploaded in flash (disk0).

When we upload the image in rommon mode we are bring the ASA in configuration but that really not upload the image in flash.

If you reload the firewall .. you are back where you started. Therefore, first upload the image from rommon ... to bring the firewall to configuration prompt then use "copy tftp flash" command..

Make sure config register is also set correctly .. else give a commnd in configuration pormpt.

config-register 0x11

Hope this helps and rate if it works for you..




This Discussion