call manager connect ccme

Answered Question
Aug 17th, 2008
User Badges:

Hi everyone:

I make a experiment to simulate call manager and ccme on one pc, below is the sketch map:


ccm ----R1----R2------IP communicator 2(4803)

| (gateway) (CCME)

|

IP communicator 1 (4604)


Now IP communicator 1 can call IP communicator 2(4604---->4803) ,but 4803 cannot dial 4604, My ccm version is 5.0.1,ccme version is telephone-service 3.3 , R1 is the gateway of ccm , R2 is the ccme that ip2 register to it ,below is two router's show run , who can tell me what can I do ?


R1 show run:

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R1

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

no ip domain lookup

!

interface FastEthernet0/0

ip address 5.x.x.x.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 172.18.1.254 255.255.255.0

duplex auto

speed auto

h323-gateway voip interface

h323-gateway voip bind srcaddr 172.18.1.254

!

ip http server

no ip http secure-server

!

ip forward-protocol nd

ip route 172.17.1.0 255.255.255.0 5.0.0.2

!

control-plane

!

sccp local FastEthernet1/0

sccp

sccp ccm 172.18.1.1 priority 1

!

dial-peer voice 2000 voip

destination-pattern 46..

session target ipv4:172.18.1.1

!

dial-peer voice 10 voip

destination-pattern 48..

session target ipv4:172.17.1.1

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

!

end

---------------------------------------


R2 show run:

!

version 12.4

service config

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname R2

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

memory-size iomem 5

!

!

ip cef

no ip domain lookup


interface FastEthernet0/0

ip address 5.0.0.2 255.255.255.0

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 172.17.1.1 255.255.255.0

duplex auto

speed auto

!

ip http server

no ip http secure-server

!

ip forward-protocol nd

!

ip route 172.18.1.0 255.255.255.0 5.0.0.1

control-plane

!

dial-peer voice 10 voip

destination-pattern 48..

session protocol sipv2

session target ipv4:172.17.1.1

!

dial-peer voice 20 voip

destination-pattern 46..

session target ipv4:172.18.1.1

!

telephony-service

max-ephones 2

max-dn 2

ip source-address 172.17.1.1 port 2000

auto assign 1 to 2

create cnf-files version-stamp Jan 01 2002 00:00:00

max-conferences 4 gain -6

transfer-system full-consult

!

!

ephone-dn 1 dual-line

number 4803

!

!

ephone-dn 2 dual-line

number 4804

!

!

ephone 1

mac-address 000C.2900.E613

type CIPC

button 1:1

!

!

!

ephone 2

!

!

!

line con 0

exec-timeout 0 0

line aux 0

line vty 0 4

!

!

end


Correct Answer by Marwan ALshawi about 8 years 9 months ago

first

u dont need dial-peer voice 10 voip on router 2


on both routers add the following


voice service voip

allow connection h323 to h323



then


make sure that the h323 gateway defind corectly on the CCM for example make sure is has enogh rights to call the ip comunicator 1

through partitions and CSS

if u use them


also i would suggest u to replace the following.. because u have PROBLEM with the DESTINATION IPs


replace:

dial-peer voice 20 voip

destination-pattern 46..

session target ipv4:172.18.1.1


to


dial-peer voice 20 voip

destination-pattern 46..

session target ipv4:5.0.0.1



and also:


dial-peer voice 10 voip

destination-pattern 48..

session target ipv4:5.0.0.2


i mean change the distination IPs



good luck


please if helpful Rate






  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Correct Answer
Marwan ALshawi Sun, 08/17/2008 - 21:55
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

first

u dont need dial-peer voice 10 voip on router 2


on both routers add the following


voice service voip

allow connection h323 to h323



then


make sure that the h323 gateway defind corectly on the CCM for example make sure is has enogh rights to call the ip comunicator 1

through partitions and CSS

if u use them


also i would suggest u to replace the following.. because u have PROBLEM with the DESTINATION IPs


replace:

dial-peer voice 20 voip

destination-pattern 46..

session target ipv4:172.18.1.1


to


dial-peer voice 20 voip

destination-pattern 46..

session target ipv4:5.0.0.1



and also:


dial-peer voice 10 voip

destination-pattern 48..

session target ipv4:5.0.0.2


i mean change the distination IPs



good luck


please if helpful Rate






3dtgnt_ljm Sun, 08/17/2008 - 22:50
User Badges:

haha! You are great ! you resolve my problem !thank you very much!! Now I can dial from A to B and from B to A!

Marwan ALshawi Sun, 08/17/2008 - 23:42
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

u welcome!!!

but thorugh ur rating i though not solved completly:)


anyway good luck

Actions

This Discussion