MGCP and timeslots range redefenition

Unanswered Question
Aug 18th, 2008

Hi,

Call Manager version is 4.2(3).

I'm configuring 2821 with PVDM2-16 and VIC2-2FXS cards to support ISDN PRI over MGCP with Backhauling.

Due to DSP quantity limitation the only timeslots I can use for PRI is 14. And it works.

After all the configurations in CM and on GW are completed by saying "sh isdn service" I see

the first fourteen TS are in IDLE state. And, as you can see, that is the things I need. All is fine !

The problem occurs after restart of CM in 'Servicability | Control Center | Call Manager process'.

The subject is Call Manager, as MGCP Call Agent, upload onto the gateway (after CM restart) the range of

1-28 timeslots. If literally, I got

{

contr X/Y/Z

pri-group timeslots 1-28 service mgcp

instead of

contr X/Y/Z

pri-group timeslots 1-14,16 service mgcp

}

How this should be fixed ?

I mean how to exclude dependency of the MGCP gateway from manual CM restarts iterations ?

Or might it be possible to firmly specify timeslots range in the Call Manager configuration ? I haven't found it.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Tobivan_Helden_2 Tue, 08/19/2008 - 00:10

Jamal,

Good doc in terms of limiting valid timeslots ragne for specific MGCP GW, thank you.

But unfortunately, I cannot make it workable. Please, advice.

Once again: due to PVDM2 model, a have a limitation for 14 voice channels, i.e. 14 timeslots.

Then in according to the doc you provided I've configured on the Call Manager the following:

- Under 'Service | Service Parameters | Call Manager Service | Change B-Channel Maintenance Status 1 '

I've specified the value 'S0/SU1/[email protected] = 0000 0000 0000 0020 2222 2222 2222 2222'

- Then 'Device | Gateway | Inhibit restarts at PRI initialization' checkbox is off

- Then 'Device | Gateway | Enable status poll' checkbox is on

- Then gateway has been resetted

Then after saying 'show isdn services' on the gateway, I got

{

#sh isdn service

PRI Channel Statistics:

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN Se0/1/0:15, Channel [1-31]

Configured Isdn Interface (dsl) 0

Channel State (0=Idle 1=Proposed 2=Busy 3=Reserved 4=Restart 5=Maint_Pend)

Channel : 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

State : 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 3 0 0 0 0 0 0 0 0 0 0 0 0 3 3 3

Service State (0=Inservice 1=Maint 2=Outofservice 8=MaintPend 9=OOSPend)

Channel : 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1

State : 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 2 0 0 0 0 0 0 0 0 0 0 0 0 2 2 2

}

As you can see, service state of the channels is INSERVICE. But I want they to be OUTOFSERVICE !

Please note that while resetting the gateway through CM Administration interface

I got the following iterative output, produced by 'debug isdn q931':

{

Aug 19 06:38:16.313: ISDN Se0/1/0:15 Q931: TX -> RESTART pd = 8 callref = 0x0000

Channel ID i = 0xA98381

Exclusive, Channel X

Restart Indicator i = 0x80

Aug 19 06:38:16.321: ISDN Se0/1/0:15 Q931: RX <- RESTART_ACK pd = 8 callref = 0x8000

Channel ID i = 0xA98381

Exclusive, Channel X

Restart Indicator i = 0x80

where X varies in between [1;14] interval

}

dezoconnor Wed, 08/20/2008 - 08:09

To get this working remove the command

ccm-manager config

from the MGCP gateway.

That way, if/when either your CCM or gateway reload they won't download their config from the callmanager TFTP. Before running this command ensure that you're back to running only 14 ISDN channels.

I've been using fractional E1's for many years and this has been my way round the issue. Cisco stance may be that fractional E1's aren't supported.

HTH

Actions

This Discussion