EIGRP default route not showing up in routing table.

Unanswered Question
Aug 18th, 2008

I changed the way I distribute the EIGRP default route. The old way was I had our last-hop router configed with a static default route to our firewall inside interface of 16x.xx.100.66 like:

interface FastEthernet0/0

ip address 16x.xx.100.129 255.255.255.128

!

interface FastEthernet0/1

ip address 16x.xx.15.125 255.255.255.128

router eigrp 1

redistribute static

network 16x.xx.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 16x.xx.100.166

Then in all the other routers I had this:

router eigrp 1

network 16x.xx.0.0

no auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 16x.xx.15.125

When I did a 'sh ip route' on a remote router the default would show up like:

MDF-Lab-3845#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 16x.xx.15.125 to network 0.0.0.0

I decided to get away from having a static default route defined in all routers, and instead changed the last-hop router to redistribute a default route. This router also has other static routes defined so I'm using a route-map to only redistribute the default route as:

router eigrp 1

redistribute static route-map default

network 16x.xx.0.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 16x.xx.100.166

ip route 12.10.132.226 255.255.255.255 16x.xx.100.159

ip route 12.10.132.232 255.255.255.255 16x.xx.100.159

ip route 12.10.132.233 255.255.255.255 16x.xx.100.159

!

access-list 1 permit 0.0.0.0

!

route-map default permit 10

match ip address 1

Then I removed the 'ip route 0.0.0.0 0.0.0.0 16x.xx.15.125' from a remote router.

Now when I do a 'show ip route' on that remote router, nothing shows up as a default route, or a candidate default route.

MDF-Lab-3845#sh ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

I tested that default route does work behind that remote router by opening up a browser on a PC behind the router and was able to get on http://www.cisco.com. Also a traceroute on this remote router to http://www.cisco.com gives no information either, ie:

MDF-Lab-3845#traceroute 198.133.219.25

Type escape sequence to abort.

Tracing the route to http://www.cisco.com (198.133.219.25)

1 * * *

2 * * *

3 * * *

4 * * *

5 * * *

6 * * *

7 * * *

8 * * *

9 * * *

10 * * *

11 * * *

12 * * *

13 * * *

14

Should there be some kind of a reference to a default route in the EIGRP routing table on this remote router? How do I know that default route is indeed being redistributed other than testing on a PC?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Richard Burts Mon, 08/18/2008 - 08:19

Jim

In the bits of the config that you posted where you are redistributing static routes with the route map there is not any sign that you are specifying any default metric for the redistribution. I suggest that you add the command:

default-metric 10000 1000 200 50 1500

under the router eigrp command and see if it works better.

HTH

Rick

jkeeffe Mon, 08/18/2008 - 08:26

Hi Rick - I understand that I can skip the metrics when all I'm doing is redistributing a static route.

If I don't issue the metric, the interface metrics are taken.

What are your thoughts on that?

Richard Burts Mon, 08/18/2008 - 08:29

Jim

My thoughts are that I would like to see what happens when you do specify the default metrics.

HTH

Rick

jkeeffe Mon, 08/18/2008 - 08:35

I'll give it a try tonight.

Would you give me a brief explanation of the metrics default-metric 10000 1000 200 50 1500 ?

Thanks

Richard Burts Mon, 08/18/2008 - 08:47

Jim

There are 5 parameters specified in the default-metric command for EIGRP. They are (in order) bandwidth, delay, reliability, load, MTU.

The first 2 (bandwidth and delay) are used in the normal calculation of EIGRP metrics. The next 2 (reliability, load) are not used by default but could be used if the K values were adjusted in EIGRP (and I urge you to not change the K values). And the last (MTU) is never used in the calculation, but it must still be specified.

The values that I typically use and recommended to you are moderately attractive (but not really attractive) values for EIGRP:

bandwidth 10000

delay 1000

reliability 200 (out of a possible 255)

load 50 (out of a possible 255)

MTU 1500

HTH

Rick

jkeeffe Mon, 08/18/2008 - 08:52

Rick - One last question if I may. Is the bandwidth parameter in kbits, so 10000 would refer to a 100mb fastethernet link? If the link is a gig link would I bump it up to 100000?

- Jim

Richard Burts Mon, 08/18/2008 - 09:04

Jim

Yes the bandwidth is in kbits and if you want to bump it up for gig you may certainly do so.

I typically do not bother to try to make it "accurate" since the default-metric is just some number for EIGRP to use when it has to have a number. If you were redistributing static and happen to have static routes going out more than 1 interface your default-metric might be right for one interface and not right for the other(s).

As I look at the question another aspect of it seems to me to be that accurate metrics are good when we really know the topology to the destination (as we typically do with EIGRP internal routes). But when we do not really know the topology to the destination (as we typically do not when we redistribute routes) then real accuracy may not be attainable.

So do what you want to do with the value for bandwidth.

HTH

Rick

Edison Ortiz Mon, 08/18/2008 - 10:25

Hi Jim,

I totally agree with Rick that the only thing that is stopping your configuration is the default-metric under the EIGRP process or during the redistribution.

With that said, I tried to duplicate your configuration and it worked w/o specifying the default-metric either on the redistribution or under the EIGRP process.

I believe that's being corrected on newer IOSes since I tested on 12.4(17). What IOS version are you running?

BTW, to confirm the metric behavior, please take a look at this URL:

http://www.cisco.com/en/US/docs/ios/iproute/configuration/guide/irp_ip_prot_indep_ps6350_TSD_Products_Configuration_Guide_Chapter.html#wp1056539

HTH,

__

Edison.

jkeeffe Mon, 08/18/2008 - 10:37

Hi Edison -

The IOS is 12.4(9)T7. By the way I was wrong in my first post thinking that default route was working because I could go to a web site on the internet. Then I realized I'm able to browse the internet because the PC is configured to use a proxy server that is behind another router that I haven't removed the static default-route statement from yet.

So in fact default route is NOT being redistributed. I'll add the default-metric statement in and let you and Rick know how it goes.

Actions

This Discussion