Need help with PC trying to get DHCP behind a C3560

Unanswered Question
Aug 18th, 2008

ok,

I have a Mitel IP phone setup with a static IP address of 10.98.9.100/23 connected to a C3560. The port on the C3560 is setup as:

interface FastEthernet0/19

switchport trunk encapsulation dot1q

switchport trunk native vlan 104

switchport mode trunk

mls qos trust cos

end

Voice is on VLAN 108

Data is on VLAN 104

There is a PC behind the phone trying to get an IP via DHCP which is 10.98.4.20 on VLAN 104 but is not getting it...

The vlan 104 is our data vlan.

The C3560 is connetced from G0/1 to a CORE 6500 on port G1/47

G0/1 on 3560:

interface GigabitEthernet0/1

description TrunkPort to Core SW3 MOD1-47

switchport trunk encapsulation dot1q

switchport mode trunk

mls qos trust cos

end

6500 G1/47:

interface GigabitEthernet1/47

description PIPSCORPSTACKDRC

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 104,108,200,1052

switchport mode trunk

no ip address

speed 1000

duplex full

mls qos trust cos

end

I cannot for the life of me figure out why this is not working.

The weird thing is some PC's work, some dont. Seem to be tied to a system with Broadcom (DELL) nic...

Anyone have an idea?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
garytayl Mon, 08/18/2008 - 08:31

Try adding:

switchport voice vlan 108

spanning-tree portfast

If no change then remove the trunk and make it an access port of vlan 104 and add those same two commands.

pipsadmin Mon, 08/18/2008 - 08:47

I dont think this will work, and the reason is the phone's port tag's with VLAN 108.

I sniffed the port on the switch and I do see the DHCP request comming out, with source 0.0.0.0 and dest 255.255.255.255

garytayl Mon, 08/18/2008 - 08:59

In regards to the tagging, when using that swichport voice vlan command the following happens:

"the IP phone forwards voice traffic in IEEE 802.1Q frames, tagged with the specified VLAN ID. The switch puts IEEE 802.1Q voice traffic in the voice VLAN"

Giuseppe Larosa Mon, 08/18/2008 - 11:19

Hello Nelson,

try making vlan 104 the native vlan or data vlan

switchport access vlan 104

switchport voice vlan 108

if you need multiple vlans after the phone

you will need to configure the PC NIC to handle 802.1Q tags.

In this way in our network we can get a PC to get via DHCP two IP addresses in different vlans.

try switchport trunk vlan native 104

But If the PC NIC doesn't support 802.1Q tagging you have to put it in a single Vlan.

Hope to help

Giuseppe

Actions

This Discussion