PPPoE in Cisco 1841 router with dynamic ip address

Unanswered Question
Aug 19th, 2008

Hello

can anybody please help me.

we are implementing new Cisco 1841 router in our network, previously we are having Wimax internet connection, now we need this router to be configured as PPPoE client that get dynamic IP address form the PPPoE server, can any body give me complete configuration to overcome with this problem, assuming that the ISP provide us with this information

1. PVC 0/50

2. PAP used as authentication type

3. user name and password

Note : there is no ATM interface in this router.

so please your urgent response will help us get ride of this. thank you

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Giuseppe Larosa Tue, 08/19/2008 - 04:10

Hello Ala,

use the following doc

http://www.cisco.com/en/US/tech/tk175/tk15/technologies_configuration_example09186a0080126dc0.shtml

remenber to define the ACL for interesting traffic

example:

interface Dialer1

description PPPoverETHERNET

ip address negotiated

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication pap callin

ppp chap refuse

ppp pap sent-username username password xxx

!

Hope to help

Giuseppe

alaeldien Tue, 08/19/2008 - 23:40

Dear Giuseppe

thank you for your effort

but i've tried and it dosn't work

when iam pinging to address it shows me msg like this

"Unrecognized host or address, or protocol not set

Can you advise please with my thanks

alaeldien Wed, 08/20/2008 - 01:53

User Access Verification

My router#show running-config

Building configuration...

Current configuration : 1827 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname falcon

!

boot-start-marker

boot-end-marker

!

enable secret xxx

enable passwordxxx

!

no aaa new-model

!

resource pol

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

no ip routing

no ip cef

!

!

no ip dhcp use vrf connected

!

!

no ip domain lookup

vpdn enable

vpdn ip udp ignore checksum

!

vpdn-group 1

request-dialin

protocol pppoe

!

!

!

!

!

interface FastEthernet0/0

description ADSL LAN Interface

ip address 10.10.10.1 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

no ip route-cache

no ip mroute-cache

speed auto

half-duplex

no cdp enable

no mop enab

!

interface FastEthernet0/1

description ADSL WAN Interface

no ip address

no ip unreachables

no ip proxy-arp

no ip route-cache

no ip mroute-cache

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

no cdp enable

!

interface Dialer1

description PPPoverEthernet dial interface

ip address negotiated

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname alaeldien

ppp chap password 0 4576jfhffh

ppp chap refuse

ppp pap sent-username [email protected] password 0 4576jfhffh

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

no ip http server

ip nat inside source list 1 interface Dialer1 overload

ip nat inside source list acl1 pool pool1

!

access-list 1 permit 10.0.2.0 0.0.0.255

access-list 1 permit 10.0.0.0 0.255.255.255

dialer-list 1 protocol ip permit

snmp-server community public RO

no cdp run

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

end

Giuseppe Larosa Wed, 08/20/2008 - 11:40

Hello Ala,

a router for routing needs ip routing

you have:

no ip routing

no ip cef

!

I strongly recommend you to turn on ipv4 unicast routing with

ip routing

ip cef

in global config mode

Hope to help

Giuseppe

Actions

This Discussion