FWSM 3.2(7) TFTP to Flash Errors

Unanswered Question
Aug 19th, 2008

Has anyone seen this problem before? I am trying to TFTP a new ASDM image to my FWSMs, but the transfer keeps failing. This is what I get on the CLI:

Accessing tftp://CLIENTIP/asdm-6112f.bin...

WARNING: TFTP download incomplete!

%Error reading tftp://CLIENTIP/asdm-6112f.bin (Unspecified Error)

%Error writing to flash:asdm ()

The FWSMs are in active/standby, but I am a bit hesitant to just reboot the standby if there is problem with the flash. Any thoughts?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
robertson.michael Tue, 08/19/2008 - 08:17

Hi Jeremy,

Forgive me if you've already confirmed this, but just to get the basics out of the way:

1. Is your FWSM in multiple context mode? If so, are you issuing this command from the system space? Also, does the Admin context have connectivity to the TFTP server?

2. Can you ping the TFTP server from the FWSM?

3. Is the TFTP server up and running on the host?

4. Does the TFTP server have any host-based firewall that would be blocking this connection?

If you've already confirmed these things, check your TFTP server's logs for anything that might point to a connectivity or permission issue (and also to make sure that the request is even getting to the server).

Also, as strange as it sounds, I've had odd behavior between the FWSM and certain TFTP servers. I would recommend trying an alternate TFTP server software, or even trying an FTP server and see if the issue persists.


jedson328 Tue, 08/19/2008 - 08:33

It appears the TFTP server I was using was at fault(tftpd32). I tried the transfer again using PumpKIN and it worked just fine.



This Discussion