SPAN session in Cisco 3750 switch stack

Unanswered Question
Aug 19th, 2008

I tried to SPAN 3 source ports into a single destination port in a Cisco 3750 stack stack. Each time after I added the monitor session 1 destination statement, the destination port line protocol went down even thought a PC is connected. What is wrong with my configurations?

Switch stack consisted of 4 WS-C3750G-48PS 12.2(25)SEB4 C3750-IPBASE-M

interface GigabitEthernet3/0/5

switchport access vlan 2

switchport mode access

spanning-tree portfast

interface GigabitEthernet2/0/37

switchport access vlan 107

switchport mode access

switchport voice vlan 308

spanning-tree portfast

monitor session 1 source interface Gi3/0/2 - 3 , Gi3/0/5

monitor session 1 destination interface Gi2/0/37 ingress untagged vlan 2

switch#sh mon sess all

Session 1

---------

Type : Local Session

Source Ports :

Both : Gi3/0/2-3,Gi3/0/5

Destination Ports : Gi2/0/37

Encapsulation : Native

Ingress : Enabled, default VLAN = 2

Ingress encapsulation: Untagged

switch# sh int g2/0/37

GigabitEthernet2/0/37 is up, line protocol is down (monitoring)

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
garytayl Tue, 08/19/2008 - 11:16

There is nothing wrong with the config nor with the status of 2/0/37. When a port is configured to be the destination of a monitor session, it is ment to monitor only and not to work as a regular port, reason why it was designed to stay as protocol down. Afterwards, the ingress command was added to get a destination port to receive traffic from an specified vlan however the line protocol status will remain the same (down).

Actions

This Discussion