WAAS exporting tfo logs via sftp

Unanswered Question
Aug 19th, 2008
User Badges:

Hello


Running WAAS 4.0.19.


I've stuck an issue where the CLI command on an edge WAE:


transaction-logs export sftp-server 10.1.1.1 tst1wae01 password logs/raw


...is accepted but when you then try and use the Transaction Logs page of that WAE in the Central Manager's GUI and make a different change (say the interval), the GUI throws up an error:


"Directory1 must start with forward slash"


If I put a forward slash in at the GUI and save it, the export will fail.


The export works when I force the WAE to use the line specified as per the CLI. If I do this the GUI shows the path as "logs/raw" which is what I want.


Anyway, the work around works but it is annoying because I effectively cannot use the GUI page for transaction log changes.


Has anyone else seen this?


Cheers

Cameron

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Zach Seils Thu, 08/21/2008 - 09:45
User Badges:
  • Cisco Employee,

Hi Cameron,


Why does the export fail with a leading / in the path? Is that not a valid path on the target server?


Can you perform the following debug and send the syslog.txt file:


From config mode:


logg disk prior debug


From enable mode:


transaction-log force export


Thanks,

Zach



cstockwe Thu, 08/21/2008 - 17:20
User Badges:

Hi Zach


It looks like that the SFTP server's directory I was supplied is not an absolute path. If I put in the absolute path "/home/tst1wae01/logs/raw" it works ok.


I suppose the strange thing that I was raising was the fact that the CLI will accept a command without the leading '/' but the central manager GUI won't.




Actions

This Discussion