LACP problem between 3750 and 6500

Unanswered Question
Aug 20th, 2008
User Badges:

Hello


I am trying to establish an etherchannel based on LACP between 3750 and 6500.


The problem is that the channel do not want to establish. On 3750 side it shows


6 Po6(SD) LACP Gi1/0/1(H) Gi1/0/2()


and on 6500 side it shows


Po6(SD) LACP Gi1/1(I) Gi1/2(I)


At the same time the 3750 switch has another channel already established with another 3750 and it works fine.


It looks like there is an issue between LACP on two platforms.


I am using 12.2(35)SE5 on 3750 and 122-18.SXF6 on 6500.


Does anybody have the same problem and could help me ?


Thanks in advance

Lukas

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
andrew.burns Wed, 08/20/2008 - 01:24
User Badges:
  • Gold, 750 points or more

Hi,


On the 6500 side it looks like the ports are in standalone mode which implies they don't have the same config.


Are you getting any log messages? Can you post the config?


HTH

Andrew.


lukaszkhalil Wed, 08/20/2008 - 01:35
User Badges:

Here you go.


From the 3750 side


interface GigabitEthernet1/0/1

description xxxxx

switchport trunk encapsulation dot1q

switchport trunk native vlan 299

switchport trunk allowed vlan 1

switchport mode trunk

logging event bundle-status

channel-group 6 mode active


interface Port-channel6

description xxxxx

switchport trunk encapsulation dot1q

switchport trunk native vlan 299

switchport trunk allowed vlan 1

switchport mode trunk


From the 6500 side


interface GigabitEthernet1/1

description xxxxxx

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 299

switchport trunk allowed vlan 1

switchport mode trunk

logging event bundle-status

udld port aggressive

channel-protocol lacp

channel-group 6 mode active


interface Port-channel6

description Gxxxxx

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 299

switchport trunk allowed vlan 1

switchport mode trunk

no ip address


The only log messages I get are:

On 3750 side


344014: Aug 20 11:31:26.101: %EC-5-UNBUNDLE: Interface Gi1/0/1 left the port-channel Po6

Aug 20 11:31:26.110: %EC-5-UNBUNDLE: Interface Gi1/0/1 left the port-channel Po6 (xxxx)

344015: Aug 20 11:31:30.086: %EC-5-BUNDLE: Interface Gi1/0/1 joined port-channel Po6

Aug 20 11:31:30.094: %EC-5-BUNDLE: Interface Gi1/0/1 joined port-channel Po6 (xxxx)

344016: Aug 20 11:31:35.454: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet1/0/2, changed state to up


From 6500 side:

The is no logs except the information that loopguard from time to time is blocking the port 1/1.


glen.grant Wed, 08/20/2008 - 03:32
User Badges:
  • Purple, 4500 points or more

The udld port aggressive on the 6500 may be causing a problem if you don't have it on the 3750 which i don't see. On trunks/etherchannels the parameters have to be exactly the same . something to try , either pull udld off the 6500 or add to the 3750 and then check to make sure udld is working correctly. I have also found that bringing both ports at the same time sometimes helps.

andrew.burns Wed, 08/20/2008 - 04:27
User Badges:
  • Gold, 750 points or more

Hi,


I only see the config for one port at each end - are the other ports identically configured?


Also, can you post a "show etherchannel detail".


Andrew.


lukaszkhalil Wed, 08/20/2008 - 05:16
User Badges:

For now we left only one port in this port-channel of 6500 side (gi 1/2) and 3750 side (1/0/2)


On 6500 side:


Group: 6

----------

Group state = L2

Ports: 1 Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol: LACP

Minimum Links: 0

Ports in the group:

-------------------

Port: Gi1/2

------------


Port state = Up Sngl-port-Bndl Mstr Not-in-Bndl

Channel group = 6 Mode = Active Gcchange = -

Port-channel = null GC = - Pseudo port-channel = Po6

Port index = 0 Load = 0x00 Protocol = LACP


Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.

A - Device is in active mode. P - Device is in passive mode.


Local information:

LACP port Admin Oper Port Port

Port Flags State Priority Key Key Number State

Gi1/2 SA indep 32768 0x6 0x6 0x102 0x7D


Age of the port in the current state: 0d:03h:41m:15s


Port-channels in the group:

----------------------


Port-channel: Po6 (Primary Aggregator)


------------


Age of the Port-channel = 13d:23h:49m:48s

Logical slot/port = 14/1 Number of ports = 0

Port state = Port-channel Ag-Not-Inuse

Protocol = LACP



On 3750 side:


Group: 6

----------

Group state = L2

Ports: 1 Maxports = 16

Port-channels: 1 Max Port-channels = 16

Protocol: LACP

Ports in the group:

-------------------

Port: Gi1/0/2

------------


Port state = Up Mstr Assoc In-Bndl

Channel group = 6 Mode = Active Gcchange = -

Port-channel = Po6 GC = - Pseudo port-channel = Po6

Port index = 0 Load = 0x00 Protocol = LACP


Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.

A - Device is in active mode. P - Device is in passive mode.


Local information:

LACP port Admin Oper Port Port

Port Flags State Priority Key Key Number State

Gi1/0/2 SA bndl 32768 0x6 0x6 0x2 0xD


Partner's information:


LACP port Oper Port Port

Port Flags Priority Dev ID Age Key Number State

Gi1/0/2 SA 32768 001e.7a82.5840 18s 0x6 0x102 0x75


Age of the port in the current state: 0d:00h:00m:14s


Port-channels in the group:

---------------------------


Port-channel: Po6 (Primary Aggregator)


------------


Age of the Port-channel = 13d:23h:50m:51s

Logical slot/port = 10/6 Number of ports = 1

HotStandBy port = null

Port state = Port-channel Ag-Inuse

Protocol = LACP


Ports in the Port-channel:


Index Load Port EC state No of bits

------+------+------+------------------+-----------

0 00 Gi1/0/2 Active 0


Time since last port bundled: 0d:00h:00m:16s Gi1/0/2

Time since last port Un-bundled: 0d:00h:00m:19s Gi1/0/2



andrew.burns Wed, 08/20/2008 - 05:49
User Badges:
  • Gold, 750 points or more

Hi,


So it's working OK now with just one port in the channel?


Andrew.


lukaszkhalil Wed, 08/20/2008 - 06:59
User Badges:

Unfortunately not. We have reduced numer of ports to check if it is a problem with the number of interfaces. But it seems not.

lukaszkhalil Wed, 08/20/2008 - 22:54
User Badges:

I have found that the problem occurs only when I use different native vlan than the default one on LACP etherchannel between 3750 and 6500.


When I have configured the LACP channel with the default native vlan I was able to stablish a LACP connection.


There is also no problem with establishing a trunk between those two platforms with the native vlan set to 299 without LACP etherchannel.


So it looks like there is some missmatch in the way the native vlan is processed on each platform and set in the LACP packets.


Lukas

Actions

This Discussion