More than one Windows ACS Remote Agent

Answered Question
Aug 20th, 2008
User Badges:

We recently added a second Windows Remote Agent to have Windows authentication service available for our two ACS.


Agent definition (CSAgent.ini) is correct but in Network Configration - Remote Agent (on each ACS web console) we see that the second Remote Agent is "available" but "not in use" (while the first one is, of course).


If we stop the CSAgent Service on the first Remote Agent server, we do not see any activity on the second one (auth not working) and service still remains "avilable" but "not in use".


Then, debugging with csagent.exe -z -p all we can see is something like:


Debug printing on..

Logging mode: LOW

ACSRemoteAgent server starting ==============================

Running as console application.

Will listen on port 2004

Configuration will be fetched from 10.1.1.101:2003

Agents: CSWinAgent

CSWinAgent File: ..\bin\CSWinAgent.exe

CSWinAgent Port: 2005

1 agents configured

Permitted CSAgent Clients: 10.1.9.10-11

Hit Return/Enter to stop...


Listener activated

Watchdog activated

CSWinAgent launched

Client connecting from 10.1.9.10:4346

RPC: Info request received

RPC: Info reply sent

Client disconnected, thread 944 terminating

Client connecting from 10.1.9.10:4347

RPC: Info request received

RPC: Info reply sent

Client disconnected, thread 2108 terminating

Client connecting from 10.1.9.10:4348



and, in the CSWinAgent log windows we see NO logs at all....


Where are we wrong???

Correct Answer by Jagdeep Gambhir about 8 years 6 months ago

You need to make ACS to use that remote agent.


ACS--->Ext DB config--->Database configuration-->Windows--->Configure--->Remote agent----> Select that RA as secondary acs and hit submit.


Now it should say in use and available aswell.


Regards,

~JG


Do rate helpful posts

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Jagdeep Gambhir Mon, 09/01/2008 - 11:54
User Badges:
  • Red, 2250 points or more

You need to make ACS to use that remote agent.


ACS--->Ext DB config--->Database configuration-->Windows--->Configure--->Remote agent----> Select that RA as secondary acs and hit submit.


Now it should say in use and available aswell.


Regards,

~JG


Do rate helpful posts

gsabbadini Tue, 09/02/2008 - 05:35
User Badges:

Thanks! It worked.

I guess i need some more RTFM here...


Thanks again!

Actions

This Discussion