Link between switches

Unanswered Question
Aug 20th, 2008

I have a Catalyst 3500XL ( WS-C3508G-XL) with 8 Giga interfaces and a Catalyst 3550 linked with a fiber, working ok.

Now i have replaced the C3550 for a C2960.

But I cant make the link up connecting the C2960 with the 3500XL.

I had to change the fiber to another 3500XL ( WS-C3548-XL ) in order to work.

Everytime I try to change from the C3548 to the C3508G the link do not work.

I dont know what it can be.

Here is the interfaces configuration.

For the 2960:

Current configuration : 86 bytes

!

interface GigabitEthernet0/1

description link L22SW-01

switchport mode trunk

end

For the C3508 ( the one that the link doesnt work)

Current configuration:

!

interface GigabitEthernet0/4

description Switch Botafogo 24

switchport trunk encapsulation dot1q

switchport mode trunk

end

for the C3548

Current configuration:

!

interface GigabitEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
branfarm1 Wed, 08/20/2008 - 04:12

A couple of things to try:

1. Have you tried explicitly setting the trunk encapsulation on the 2960 interface?

2. Try comparing the outputs of: sh int Gi0/X switchport to see if there's anything obviously different. Also look at sh int gi0/X controller

rafael.2007 Wed, 08/20/2008 - 04:58

Branfarm1,

1- There is no explicity trunk encapsulation command in this ios version. Only works with the dot1q by default

2- I have made a compare with the commands sh int gig0/x switch port

Can you check in order to see if there is someting wrong:

From the 2960:

L24SW-02#sh interfaces gigabitEthernet 0/1 switchport

Name: Gi0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk associations: none

Administrative private-vlan trunk mappings: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

From the C3508:

L22BB-01#sh int gigabitEthernet 0/4 switchport

Name: Gi0/4

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1,10-12,20,25,100-102,200,300,400-405,500,510,555,600,

700,900-908,914,920,922,923,939-969

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

From the C3548

L24SW-01#sh int gigabitEthernet 0/1 switchport

Name: Gi0/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Protected: false

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Voice VLAN: none (Inactive)

Appliance trust: none

branfarm1 Wed, 08/20/2008 - 05:20

So when you say the link between the two switches isn't working does that mean that the trunk never actually forms and the link shows down on one side?

rafael.2007 Wed, 08/20/2008 - 05:44

Exactly it is like there is no fiber connecting them.

It is equal as I remove the fiber.

branfarm1 Wed, 08/20/2008 - 05:48

Hmm... that's an interesting one. Have you started off with the most basic of basics - tried a different piece of fiber, different GBICS or SFP's, different slots?

rafael.2007 Wed, 08/20/2008 - 07:05

Yes already tried this.

Replaced the Fiber patch cord, the gbic and changed the port, but no joy

branfarm1 Wed, 08/20/2008 - 07:47

Well, I wish I could be more help, but it sounds like we'll need to get someone with more technical troubleshooting skills involved. This is starting to appear like it's more than just a configuration issue.

On a related note, I've had this problem in the past with fiber connections between 4507's and 3020 Blade switches. I was never able to get the link to work though, so I had to switch it over to a copper connection. I'm interested to find out what the solution ends up being.

tdrais Wed, 08/20/2008 - 08:09

One thing to check on gig stuff is the flow control. I normally only have a issue between cisco and non cisco stuff.

If the ports are in a up status you may want to check and see if you see CDP neighbor or spanning tree active on vlan 1.

If these are up the next to check is for a VTP issue. When you force the ports to trunk you they will come up even if the VTP domain does not match but they will not exchange any vlan information.

branfarm1 Wed, 08/20/2008 - 09:41

Tdrais,

What does it mean if the one end of the link shows as down? That's the problem I had -- one end of the link showed up, while the other end showed down. I tried multiple cables, GBIC's, ports, etc.

Willem de Groot Wed, 08/20/2008 - 21:34

Hi

It me have something to do with the

Administrative Native VLAN tagging: enabled

Settings on the 2960.

Try to change it to no native vlan tagging (default).

Willem

t4tauseef33 Thu, 08/21/2008 - 01:02

I have the same problem a year ago,

what i have did is specified the speed and the duplex on the interfaces. Although this would not required but helped me to bring the link up.

secondly try by removed the trunk configuration on each switch.

Actions

This Discussion