updating CallManager 4.1.3 with a new firmware for a new version of phone

Unanswered Question
Aug 20th, 2008

Can I run the .exe file of a new phones firmware on Callmanager during production? Is there a reload required with this firmware install?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Chris Deren Wed, 08/20/2008 - 06:26

I dont belive reboot is required, but you will need to restart tftp service. I would strongly recommand doing this after-hours as it may spike the CPU possibly resulting in service interuptions.


Jaime Valencia Wed, 08/20/2008 - 06:35

no reboot needed when doing the install since it only puts the files on the TFTPPath and and changes the device defaults fields



if this helps, please rate

rob.huffman Wed, 08/20/2008 - 06:34

Hi Rob,

This can be done during production hours but I wouldn't. If a phone reboots after the .exe has been run it will go through the upgrade process. This might not be the best thing to have happen by accident. If working with these images during production hours I would recommend using the "Alternate' method shown below. This way you control when the upgrade actually takes place :)

Here is an example of the Install notes;

When Using Cisco Unified CallManager earlier than Release 5.0

Login to the console of the Cisco Unified CallManager Server where you downloaded the installer.

Note the location where you saved the downloaded file.

Double-click the file to start the installation.

In the Welcome window, click Next.

In the License Agreement window, click Yes.

If a Read Only File Detected window pops up, click Yes.

After the installation finishes, click OK.

Reset all corresponding devices.

Cisco IP Phone Model 7942G/7962G Alternate Firmware format

The Cisco IP Phone Model 7942G/7962G Firmware version 8.3(5) is also supplied in a zip file, as an alternative in case a Cisco Unified CallManager is not available to load the installer program. The name of this file is: cmterm-7942_7962-sccp.8-3-5.zip.

After unzipping the firmware files, they should be manually copied to the appropriate directory on the TFTP server.


Hope this helps!


rob.leetun Wed, 08/20/2008 - 11:24

So I ran this on my TFTP server and the replication to the pub has not happen after two hours. I do not see it in device types? Suggestion?


Chris Deren Wed, 08/20/2008 - 11:33

What replication are you talking about? You need to install the DevicePack on all TFTP servers in the cluster, typically the Pub is the TFTP unless it is a large cluster.

Has the default device page been updated witht he new firmware version?

You will need to restart the tftp server, and reboot the phones in order to force the phones to download the new firmaware.


Jaime Valencia Wed, 08/20/2008 - 12:16

RN explain that, install on every TFTP server.

Might be a good idea to read them before installing any kind of SW



if this helps, please rate


This Discussion