Browser-Server security mode - LMS 2.6

Unanswered Question
Aug 20th, 2008

I changed the security mode to enabled and shutdown LMS and rebooted, however, some of the url links on the homepage still attempt to open using http rather than https. Is there a configuration file that can be modified to correct the url links? The problem appears in the homepage links for Campus Manager sub-applications: home, topology services, path analysis, user tracking, VLAN port assignment and administration but is OK for discrepancy reports. For RME, only the home link uses http - sub-apps are fine.

Any ideas on how to correct the urls?

Thanks.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kviola1 Wed, 08/20/2008 - 08:30

Whopps - looks like all of the sub-links are using http, only the tool category urls are using https for Campus, RME, and CiscoView.

Thanks again.

Joe Clarke Wed, 08/20/2008 - 08:41

Re-register the problem applications by going to Common Services > Server > Homepage Admin > Application Registration. Unregister RME and Campus, then re-register them.

kviola1 Thu, 09/04/2008 - 09:44

Joe - thanks for the response. I tried unregistering and re-registering the apps but got the same result. I stopped and started the daemons after each step but still didn't work. Any other ideas? The system is due to be upgraded to LMS 3.1 soon - would that fix? I'm having the user's just insert and "s" in the url (http => https) as a workaround for now.

Joe Clarke Thu, 09/04/2008 - 09:47

An upgrade will probably not fix this. I don't see how re-registering the apps would not fix this. However, you might need to do a complete unregister/re-register from the command line. You'll need to open a TAC service request to get the instructions. You might also try disabling SSL, then re-enabling it to see if that fixes the problem before open a TAC SR.

Actions

This Discussion