unable to get one device data in Campus Manager/ vlan port assignemnt

Unanswered Question
Aug 20th, 2008

I am unable to capture vlan port assignment data of a Cisco 6509 switch is Vlan port assignment . As per the device discovery details the device has been discovered successfully (also its neighbors). Is there anyway I can resolve this issue? also the device does not appear in topology services

My CW versions are given below

Ciscoworks Common Services 3.0.6

Campus Manager 4.0.11


Vijay Sequeira

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Thu, 08/21/2008 - 07:16

The device not appearing in Topology Services is the biggest blocker to being able to use VLAN Port Assignment. Check your Data Collection filters under Campus Manager > Admin > Campus Data Collection to make sure the device is not filtered out. Also, make sure its SNMP credentials are correct in DCR. After verifying those things, run a Campus Manager Data Collection from Campus Manager > Home to see if the switch appears on the map.

vijay_sequeira Fri, 08/22/2008 - 05:27

Thank you for your reply , At present there is nothing configured in the filter. I am not able to only get data for this particualr switch , the only recent change was that the switch name was changed.

I have modified the required switch details in the DCR.

Do I need to change something else than this ?


Vijay Sequeira

Joe Clarke Fri, 08/22/2008 - 08:15

No, but since you're running LMS 2.6, you may need to restart Daemon Manager after this change. Also, is this server integrated with ACS?

vijay_sequeira Sun, 08/24/2008 - 08:08

I really do not remember if Daemon manager has been restarted after this change , I will restart daemon manager and try .

Yes this server is integrated with ACS and the troublesome device is also TACACS enabled . TACACS is working properly for the device(device was present in ACS under the old name , I have deleted this and created a fresh entry with the new name.)Should this cause the problem?

I have restarted damemon manager and will try after a couple of hrs and revert back.

I have also attached the icserver.log


Vijay Sequeira

Joe Clarke Sun, 08/24/2008 - 08:20

The ICServerUI.log has no bearing here. If the device was still in ACS under the old name, then that could explain why you weren't seeing it in Campus. Now that you've corrected that, verify the device does not show up under Common Services > Device and Credentials > Reports > Devices not in ACS. If so, restart Daemon Manager, and check again. Once the device is no longer in the report, run a new Campus Data Collection, and the device should appear on the map and in VLAN Port Assignment.

vijay_sequeira Mon, 08/25/2008 - 04:59

All necessary corrections have been done, device name has been changed to current , daemon manager has been restarted, fresh device discovery has been done , device now appears in topology services but I am still unable to get vlan port assignment data for this switch (tried with name, ip address combination)

Is there some log file on which I can check why this is not happenning ?


Vijay Sequeira

vijay_sequeira Mon, 08/25/2008 - 06:23

there is a strange event that is occuring when I had last run device discovery after doing the changes , in the data collection metrics of the Campus manager home , the troublesome device was listed under "new devices" and was appearing in topology services , I had again run device discovery but now the device is listed under "devices deleted" and no longer appears in topology services.

I am not able to understand what is happening .


Vijay Sequeira

vijay_sequeira Mon, 08/25/2008 - 18:56


The CW server uses ACS server for authentication only .(It is working in Non-ACS mode).

Authentication Mode Radius (Fallback Mode)

Authorization Mode CiscoWorks Local

Single Sign-on Mode Standalone

Devices not configured in ACS Not applicable

Also inventory is not getting collected for the device. I have increased the snmp timenout to 900seconds

the current scenario is this archive collection is happening , inventory is not working, vlan port assigment is not working


Vijay sequeira

Joe Clarke Mon, 08/25/2008 - 18:59

Inventory is a separate issue. Is the device once again on the Topology Map with a green switch icon? If so, you should be able to right-click on it, and select Port Attributes. What are the port attributes?

vijay_sequeira Tue, 08/26/2008 - 06:17

Yes the device is currently appearing in the topology map and the port attributes are displaying the port details.

But I am not able to obtain the data for the switch through VLAN port assignment.


Vijay Sequeira

Joe Clarke Tue, 08/26/2008 - 09:14

Please post a screenshot of the Port Attributes for this switch. When you say the data for the switch cannot be obtained through VLAN Port Assignment, is the switch completely missing from the device selector, or do the ports simply not show up?

vijay_sequeira Thu, 08/28/2008 - 05:00

Please find enclosed the screen shot of the port attributes,

I have also enclosed a screen shot of the device collection metrics , if you look at the device collection metrics screen shot you will see after each poll one device is added or deleted , this device is the problematic device. when the poll shows that the device is added at that time device appears in topology services and port attributes can be seen , on the next poll the device is deleted and at that time device does not appear in topology services aand port attributes cannot be seen.

In the VLAN port assignment , I select the VTP domain and then search for the port assignment with the following search criteria . I have also tried with VTP domain all

VTP Domain abcd

Find Port

[ Match all of the following]

[not Match any of the following]


Device Name

begins with



Port Description




Vijay Sequeira

Martin Ermel Thu, 08/28/2008 - 05:54

I see the device is listed with its hostname. What is the mechanism that resolves the IP address to hostname? DNS or hosts file?

You mentioned the name of the device has changed - have you also changed this in your name resolution mechanism? - Have you removed all invalid old entries?

vijay_sequeira Sat, 08/30/2008 - 04:07

DNS is the mechanism the resolves the IP address to hostname.

Yes the updated device name is present in DNS and the updated device name only resolves to the IP address.

All invalid old entries have been removed.


Vijay Sequeira

Joe Clarke Sat, 08/30/2008 - 08:25

I'm not going to have a chance to dig into this further for the next week. However, this is what I'd try. When the switch is showing up in Campus, check the VTP domain view to make sure this switch is really showing up in that VTP domain. If the switch is in VTP transparent mode, its actual domain will be VTPDOMAIN_IP(T), so make sure you're searching the correct VTP domain.

I'd also try a looser search. For example, perform a search for the following:

VTP Domain : All

Device Name is DCA301S4-SHARED

When this device is showing up in CM, I see no reason why this search pattern wouldn't find it.

As for troubleshooting why the switch is disappearing, you can enable core and corex Data Collection debugging under Campus Manager > Admin > Campus Data Collection > Debugging Options, run a new Data Collection, and get the ani.log. Then open a TAC services request to see what is going on.


This Discussion