Switch IP not seen by cdp neighbors detail

Answered Question
Aug 20th, 2008

Hi All

Switch IP not seen by cdp neighbors detail

I have my switch in vtp transparent mode, created vlan's and a vlan Interface

Now, when i do a CDP neighbors detail from

I see my switch but no IP


Entry address(es):

IP address:

I neighter can ping the switch from the neighbor.

Here a part of my config:

vlan internal allocation policy ascending


vlan 115

name LD-VLAN-Management


interface GigabitEthernet0/25

description Glas to Zuerich

switchport trunk encapsulation dot1q

switchport trunk native vlan 115

switchport trunk allowed vlan 115,868,869

switchport mode trunk

macro description cisco-switch

auto qos voip trust

spanning-tree link-type point-to-point


interface Vlan115

description Management VLAN

ip address


How can i get this to work.

I don't want my neighbor to have learn my VLAN's

This is a Production-switch, i can't just play around!

Who can help me?



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
massimiliano.se... Wed, 08/20/2008 - 22:51


The native VLAN is the same on other lik? That is on the other switch (the switch which is attached to "transparent-switch"), is the vlan native the same?

Best regards.


Willem de Groot Wed, 08/20/2008 - 22:58

Hi Massimiliano

Yes, the native vlan on the other site is the same.

The trunk is up and running.

There is lots of traffic flowing even on different vlan's (868 and 869), transport works fine, just can't see the IP.

So i can't get remote on this switch,

Can't ping it.

massimiliano.se... Wed, 08/20/2008 - 23:05


From that you're sayng the layer 2 connectivity is good. A problem might be layer3 connectivity....the subnet mask of the vlan is the same on the two switches?


Willem de Groot Thu, 08/21/2008 - 06:11

Hi All

Thanks for the feedbacks!

"the Nativ Vlan should be same and the Mgmt Vlan should have been given the IP address means vlan 1" brought me on the point.

Looking at my config, i allowed only vlan 115,868 and 869 NOT vlan 1 !!

Also i had vlan 115 as native vlan, on the other end there was no such statement, so vlan 1 was native there.

Thanks all



This Discussion