User Tracking and SNMPv3

Answered Question
Aug 21st, 2008

Hi,

I read somewhere in the forum that it is not possible to take UT data out of a 2950G switch by using SNMPv3.

Is it not possible on 3560 switch, too?

I want to manage our devices with SNMPv3, but we also need the UT informations.

Is it possible to configure Campus Manager to use SNMPv2 for UT and all other applications have to use SNMPv3?

Thanks!

Sven

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 8 years 5 months ago

That is correct. Any device with a sysObjectID listed in the NoSnmpContext property in NMSROOT/campus/etc/cwsi/ANIDevice.properties will not be contacted with SNMPv3 in UT.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Joe Clarke Thu, 08/21/2008 - 06:59

Correct, only devices which can run 12.2 code can support SNMP contexts. If the 3560 is running 12.2(25)SEE or higher, then you can configure SNMPv3 contexts on it, and UT will be able to get end host data.

It is not possible to configure Campus to use v2 while other apps use v3. However, I have filed a bug which will tell Campus to use v2 for devices which can never support SNMPv3 contexts. This bug was fixed in LMS 3.1.

Sven Hruza Fri, 08/22/2008 - 04:37

Okay, I will check the 3560 switches once again.

We use LMS 3.1, so I can configure a snmp RO community and SNMPv3 on the switch and in DCR and CM uses the SNMPv2 settings automatically for UT?

Fine!

Thanks a lot!

Sven

Correct Answer
Joe Clarke Fri, 08/22/2008 - 08:09

That is correct. Any device with a sysObjectID listed in the NoSnmpContext property in NMSROOT/campus/etc/cwsi/ANIDevice.properties will not be contacted with SNMPv3 in UT.

Sven Hruza Mon, 08/25/2008 - 05:46

Hi!

Is there any OID which I can read by SNMP or something else for UT?

I tested SNMPv3 with a 3560 switch with 12.2(25)SEE4 IOS and it doesn't work.

Thanks!

Joe Clarke Mon, 08/25/2008 - 08:02

You need to make sure you have configured SNMPv3 contexts on the switch. Do a show snmp context. For each one of those vlan-* contexts, you need to add a command like the following:

snmp-server group v3group v3 auth context vlan-10

Actions

This Discussion