QOS for Call Manager

Unanswered Question
Aug 21st, 2008


I have a SIP trunk between CUCM 5.1 and a CME site over MPLS. I have a priority queue setup for traffic that is marked as EF. When I watch traffice between the CUCM and CME I see the conneciton for the SIP trunk but there is no markings for the VOIP call. Because the traffic is not being marked the calls are not using QOS. If I watch a call here in my local office I see the traffic marked between 2 phones. How can I mark the traffic from my call manager to the CME as EF? Will it hurt of help if I add something like mls qos trust to the call manager ports on the switch?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Ayodeji oladipo... Thu, 08/21/2008 - 08:04

The best practice is to mark as close as possible to the source. That means you should mark and on the swicth and then classify the marked traffic on the routers.

mls qos is used to enable qos on the switch.

Usually cisco IP Phones have their traffic marked by default, so you will just need to ocnfigure the switch to trust the marked traffic from the ip phones..

HTH, pls rate useful posts

wbarren Thu, 08/21/2008 - 08:17

The traffic from the IP phone is being marked. When I sniff the traffic I am not seeing the traffic from the phone but from the Call manager to the CME over the SIP trunk. This is the traffic that is not being tagged.

Ayodeji oladipo... Thu, 08/21/2008 - 09:12

If the traffic from the IP Phone has been marked and qos is enabled on the switch, the ip phone traffic over the sip trunk should be marked too..IS QOS enabled on your switch?

wbarren Thu, 08/21/2008 - 09:45

Here is how my switchports and QOS are setup. I have also put the port for call manager here.

interface GigabitEthernet5/2

switchport access vlan 10

switchport mode access

switchport voice vlan 100

qos trust device cisco-phone

qos trust cos

auto qos voip cisco-phone

tx-queue 3

bandwidth percent 33

priority high

shape percent 33

spanning-tree portfast

spanning-tree bpduguard enable

service-policy output autoqos-voip-policy

qos dbl

qos map dscp 24 25 26 27 28 29 30 31 to tx-queue 4

qos map dscp 32 33 34 35 36 37 38 39 to tx-queue 4

qos map cos 3 to dscp 26

qos map cos 5 to dscp 46


interface GigabitEthernet3/9

description Call Manager

switchport access vlan 3

no cdp enable

When I sniff the traffic from the switch to my router I do not see traffic from the phone. I am seeing traffic from my call manager to the CME over the SIP trunk and it has no dscp marking.

mhering8650 Thu, 08/21/2008 - 10:44

on the switch ports for the CCM and routers etc add

mls qos trust DSCP

Ayodeji oladipo... Thu, 08/21/2008 - 10:44

Do you have the appriopriate policy-maps and service-policy applied in the right direction on your router

wbarren Thu, 08/21/2008 - 10:49

Here is my policy-maps and serivice policy



class-map match-all VoIP-RTP

match ip dscp ef

class-map match-all VOIP-Cntrl

match ip dscp af31

match ip dscp cs3



policy-map Voice_wan

class VOIP-Cntrl

bandwidth 256

set dscp af31

class VoIP-RTP

priority 450

set dscp ef

class class-default



policy-map MPLS-Sub

class class-default

shape average percent 75

service-policy Voice_wan



applied to

interface Multilink123

description MPLS

ip address

ip route-cache flow

load-interval 60

ppp chap hostname

ppp multilink

ppp multilink fragment disable

ppp multilink links minimum 1

ppp multilink group 123

service-policy output Voice_wan


Ayodeji oladipo... Thu, 08/21/2008 - 10:59

I assume that your virtual multilink interface has been assigned to a pysical interface...

WHen you place calls between ccm and ccme, do you see the traffic matching the policies defined ont he interface..

\you can use the command.sh policy-map interface..command

wbarren Thu, 08/21/2008 - 11:02

Nope, that is how this all started. I was looking at the sh policy-map int and could see my queues not being used. then I started to sniff and could not see any markings coming from the call manager.

Ben Cook Wed, 10/29/2008 - 07:37

I'm not sure if you ever figured this out, but you won't see anything marked from your CCM. If you would like to see CCM packets being marked, make sure you have SCCP/SIP in your access-group. Voice packets never come from your CCM. Your CCM only sets up the call, after that the call is point to point.

Tommer Catlin Wed, 10/29/2008 - 08:24

But if it's a SIP trunk, the calls would go through that Trunk and you should be able to monitor that traffic correct? CUCM will setup the call between two end points, but if goes through a trunk on CUCM, then the packets should be seen correct?


This Discussion