CME - not able to add more ephone-dns

Unanswered Question

On my 3745 router, when I try to add more ephone-dns, I get this error

*Mar 3 22:42:23.764: %DIALPEER_DB-3-ADDPEER_MEM_THRESHOLD: Addition of dial-peers limited by available memory


The following are dial peer configuration error messages.

Error Message

%DIALPEER_DB-3-ADDPEER_MEM_THRESHOLD : Addition of dial-peers limited by available memory

Explanation The available memory does not permit the addition of more dial peers.

Recommended Action To add more dial peers, increase the processor memory.

how do I add processor memory???? is this an orderable part??

pls help


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (3 ratings)
Kenneth Mohammed Sat, 08/23/2008 - 09:21

I think Paolo ran into this issue before and posted it on an earlier discussion. Check this link.

He stated that rebooting the router fixed the issue.

Hope that helped.

pcameron Sun, 08/24/2008 - 06:28

Each dial peer or ephone-dn takes up around 5-10Kbytes of memory. If you have a large number of exising dial peers or configure the maximum setting for the CME max-dn, IOS will try and reserve memory, and in some cases fails with the listed message.

More often that not, there are two reasons why this happens.

1) The configured IOmem being set too high. If you do a SH VER, there will be a line something like this -

Cisco 3825 (revision 1.1) with 489472K/34816K bytes of memory.

The two figures added together give the total memory installed in the router (512 Meg) The first figure is system memory, and the second value is the reserved IOmem. If the IOmem is set too high, it may prevent memory being reserved for confiurable settings like dial peers. You can reduce the IOmem using the config command 'memory-size iomem ' and set a smaller value.

Once the value has been changed, you will need to reload the router for the new value to take effect.

Be sure to monitor the router operation if you change this setting as it could affect other packet processing functions if the router is switching a lot of traffic.

2) Memory has been reserved by a excessively large logging buffer, for example 'logging buffered 10000000' . Remove any such commands from the system config.

Reboot did not fix my issue.

I upgraded my router from 128 MB to 256MB.

I set my meory-size iomem to 10%

I don't get the errors now but my memory utilization is between 80 - 90% - TAC says I'm good.

I still don't feel good about this. I think it is the memory leak issue which was in the old versions of IOS that is haunting again..


This Discussion