CiscoWorks

Answered Question
Aug 22nd, 2008

Hi guys,

I am new on this forum. I am running LMS 3.0.1 (Dec 2007 patch) with Campus Manager (upgraded to) 5.0.3 on Windows 2k3 Server.

My problem:

Some specific devices, like Cisco 2611 Multiservice Platform and Cisco 2651 Multiservice Platform, are not recognized by Campus Manager. I can open one of then in CiscoView/ChassiView and check the interfaces status, but I can't do the some for the other and got the message "Message Timeout on 10.230.52.2. This error could be due to lack of access to the host, invalid SNMP credentials, or a busy device.". I am sure that credentials (user/login) and communities are Ok. Both devices' icons are displayed correctly on Device Manager (Common Services and RME) instead of been displayed with "?" icon.

When I run Data Collection on Campus Manager and look the Devices on result, these devices are not listed neither in hostname column nor in neighbors column. So, I think they were not collected in Data Collection.

When I run Topology Services, I can't see these devices under any topology group. If I try to create a group on Campus Manager, these devices are not listed as devices that can be add to a group.

Does anyone know if I am doing something wrong or how can Campus Manager recognize these devices?

Thanks in advance,

Regards,

Flaviano Leoncini.

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 8 years 3 months ago

You are hitting bug CSCsm66330 which is fixed in LMS 3.1. There is an experimental patch available for LMS 3.0.1 if you contact the TAC.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
Loading.
Joe Clarke Fri, 08/22/2008 - 08:21

The CiscoView error points to either an SNMP credential problem, or a firewall or access-list issue. Use the SNMP Walk tool under Device Center > Tools > SNMP Walk to walk the starting OID of "system" on both devices. Make sure this works. If not, recheck the DCR credentials, and look for any firewall or ACLs which may be blocking udp/161.

Once that is verified, check Campus Manager's Data Collection filters to make sure the devices are not filtered out (Campus Manager > Admin > Data Collection > Device Management). If this server is integrated with ACS, make sure the devices are authorized for your System Identity User for the Campus Manager application.

flaviano.leoncini Mon, 08/25/2008 - 10:28

Hi jclarke and guys,

Thank for this tip. This seens to be the way to fix the problem, but I still couldn't fix it.

One of devices that is not been showed on Campus Manager was in the list of devices that can be included (Campus Manager > Admin > Data Collection > Device Management > Inlcude devices).

On Friday I included this device (select device and "Include" button) and run Data Collection again. After running, the device didn't appear on data collection results' device list, but it didn't appear on include devices' list again.

Today, I check the Include Device List and the device (and olny this specific device) is listed there again.

Does anyone know hat does it mean? What can be the reason for this?

Thank you,

Regards,

Flaviano.

flaviano.leoncini Mon, 08/25/2008 - 11:09

LMS has identified it as a "Cisco 2611 Multiservice Platform".

The snmpwalk, from LMS:

SNMP Walk Output

--------------------------------------------------------------------------------

system

RFC1213-MIB::sysDescr.0 = STRING: "Cisco Internetwork Operating System Software

IOS (tm) C2600 Software (C2600-IO3S56I-M), Version 12.0(7)XK2, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)

TAC:Home:SW:IOS:Specials for info

Copyright (c) 1986-2000 by cisco Systems, Inc.

Compiled Tue 31-Oct-0"

....

Thank you again,

Regards,

Flaviano Leoncini.

Joe Clarke Mon, 08/25/2008 - 11:16

Enable core and corex debugging under Campus Manager > Admin > Debugging Options > Data Collection. Then run a new Data Collection. Post the ani.log and the show run from this device. If you cannot post that information to this forum, then open a TAC service request with those items.

flaviano.leoncini Tue, 08/26/2008 - 13:14

Hi Jclarke,

Thank again for you answer.

Unfortunately I can't post these logs here, but I think I know the reason problem. That is, now I have a new issue!

The device is duplicated on Common Services database. There was one entry registered manually, with the display name registered

with the router name, like 'router_a' for instance, and another registry with display name as the router IP, discovered automatically by LMS.

The entrance with IP address is been displayed correctly on Campus Manager; I didn't realized this before. What I did for

these specific device was:

- delete, on Common Services, the entrance with router name on display name

- change the IP name on display name to router's name.

After doing this and device collection on Campus Manager, the entrance with router's name is been displayed on Campus Manager. But, after a period, a new registry is created again on Common Services' database with router IP on display name.

Shouldn't LMS identify that an entrance already exists on Common Services' database and didn't create a new registry on this

database? Is there a way to avoid this?

As I will enter all devices manually on Common Services database, is it better to disable discovering? How can I do this?

This duplicated device problem is happening for lots of devices!

Thank you,

Regards,

Flaviano Leoncini.

Correct Answer
Joe Clarke Tue, 08/26/2008 - 13:30

You are hitting bug CSCsm66330 which is fixed in LMS 3.1. There is an experimental patch available for LMS 3.0.1 if you contact the TAC.

flaviano.leoncini Wed, 08/27/2008 - 08:50

Hi jclarke,

Nice, I think that this is the main reason for my problem. I got and installed the patch and will check tomorrow if the problem was fixed. If it was not, I will need to disable the device discovery on Common Service.

Thank you very much for your help!

Regards,

Flaviano Leoncini.

Actions

This Discussion