FXO voice quality

Unanswered Question
Aug 22nd, 2008
User Badges:

Hi All,

we are using CME with 4FXO card. the voice quality is not good and it is statically in the background and the voice of caller from outside is like a robot. what parameters should I tune to fix this problem?

any suggestion will be very appreciated.


Alex


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
bgrunewald Sat, 08/23/2008 - 15:55
User Badges:

Plug a regular analog telephone into the FXO ports and see what the voice quality is like. VoIP systems are pretty immune to static, so it sounds like a line quality issue on the Telco side.

pcameron Sun, 08/24/2008 - 06:11
User Badges:
  • Cisco Employee,

By any chance have you configured 'compand-type a-law' on the FXO ports ?


If you have , take it out using the 'default compand-type' command.


Analogue voice ports take incoming audio and pass it through a PCM codec device. The default output of this codec uses ulaw coding to pass digitised audio to the DSP.


If you override this with the compand command, the DSP is still expecting ulaw so you have a alaw/ulaw mismatch, and the classic symptoms of this are static noise and distortion.


You can check here and compare -


http://www.cisco.com/en/US/tech/tk652/tk698/technologies_white_paper09186a00801545e4.shtml#stat


This is a common mistake - only digital voice ports such a ISDN BRI/PRI/CAS need the companding set. E1's and T1 default to alaw and ulaw respectively, it is normally only ISDN BRI that needs to the manually configured as a-law. Analogue lines should be left as default.

Actions

This Discussion