Cisco 857 & VoIP - NAT Problem

Unanswered Question
Aug 22nd, 2008

Hi @ll,

I try to get a Linksys PAP2 to work but always after 22 sec. the call disconnect.

I know the Cisco Router is the problem because when I switch back to my old DSL-Modem it works fine.

I used the Cisco Software to configure a NAT for the Ports 5004 and 5060 but it still disconnect.

Please Help me out :)

See my current config as attachment

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
brandon.bennett... Fri, 08/22/2008 - 09:26

Port 5060 (SIP) is just used for call setup and not for audio. So you will get one way audio (they can hear you, you can't hear them) with this setup.

Here is the Linksys guide http://www.linksys.com/servlet/Satellite?childpagename=US%2FLayout&packedargs=c%3DL_Product_C2%26cid%3D1117044308483%26site%3DUS&pagename=Linksys%2FCommon%2FVisitorWrapper Which states some addition ports to open up.

Although this presents another issue. IOS doesn't support port ranges in NAT.

What you can do is use CBAC. CBAC is part of IOSs firewall feature set which will turn on Application Layer Gateways (ALGs) to help fixup SIP for connecting through NAT firewalls as well as providing stateful firewalling.

Here is a link on configuring CBAC http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fsecur_c/ftrafwl/scfcbac.htm

And here is another link for setting up an IOS firewall for SIP phones and SIP dialing.

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t15/feature/guide/ft_fwsip.html

Hope this helps,

Brandon

Actions

This Discussion