Pix/Radius and enable mode

Unanswered Question
Aug 22nd, 2008
User Badges:

Hi all, I am trying to get a pix 6.3 to authenticate telnet users via radius with a Microsoft IAS server. This works well, but Im trying to get it where when they log in, it just dumps them into enable mode, instead of typing in the enable AD credential again. Anyone have any insight on how to do this? Its a IAS configuration thing I know, but not sure what to do with it. Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.8 (4 ratings)
Loading.
Premdeep Banga Fri, 08/22/2008 - 13:34
User Badges:
  • Gold, 750 points or more

If you mean on firewall,


Username: alfa

Password: ********


pixfirewall#


Rather then,


Username: alfa

Password: ********


pixfirewall>

pixfirewall>enable

Password: ********

pixfirewall#


The unfortunately, Pix firewall does not have this concept, like IOS devices have.


On IOS you can get the user log directly into enable (Privileged exec) mode by passing attribute,


cisco av-pair as shell:priv-lvl=n or on some IOS only using Service Type as Administrative will do the trick.


Where, n is the privilege level.


AND, there has to be an EXEC authorization command on the IOS device, e.g.,


aaa authorization exec group radius....


Unfortunately, that is not the case for the Pix firewall, they have a different OS.


Regards,

Prem


Please rate if it helps!


Farrukh Haroon Sun, 08/24/2008 - 11:11
User Badges:
  • Red, 2250 points or more

Even tough the exec authorization feature in the Cisco PIX/ASA is not 'completely' implemented, it does not mean you cannot do things like command authorization on the PIX/ASA. So let us know what exactly do you want to achieve and maybe we could help.


Regards


Farrukh

jjoseph01 Sun, 08/24/2008 - 14:42
User Badges:

Hey, thanks. When I telnet into the device, and successfully log in, Id like it to dump me directly into enable mode. routername# instead of routername>

Premdeep Banga Mon, 08/25/2008 - 03:41
User Badges:
  • Gold, 750 points or more

Unfortunately, this kind of functionality is not included in the PIX/ASA OS as of now.


Regards,

Prem

nobleton3366 Mon, 08/25/2008 - 07:25
User Badges:

Do you know if there is a plan to support this in any later versions? In my work enviroment shared passwords are not allowed. Thanks.


Premdeep Banga Mon, 08/25/2008 - 07:31
User Badges:
  • Gold, 750 points or more

You might want to contact your accounts team for the same.


If sharing of password is not allowed, then you can enable, enable password authentication on firewall, i.e.


aaa authentication enable console LOCAL


And on the ACS server, under user's profile, make sure that enable password is selected as the user's account password against the respective database.


Regards,

Prem

nobleton3366 Tue, 08/26/2008 - 05:17
User Badges:

Thanks works great thanks. One more question...


On my IOS equipment, I am able to make it check the LOCAL db first then radius rather than radius first. Is there a way to do it this way on the ASA?

Farrukh Haroon Tue, 08/26/2008 - 05:21
User Badges:
  • Red, 2250 points or more

Yes the AAA method list functionality is identical on both platforms. The IOS 'local-case' is the 'LOCAL' on ASA.


Regards


Farrukh

Premdeep Banga Tue, 08/26/2008 - 05:29
User Badges:
  • Gold, 750 points or more

I think on your IOS this is how you are doing the authentication,


aaa authentication login default local group radius...


Local first and then Radius, right ?


If I understand you situation correctly, then that functionality/behavior is not how ASA/PIX firewall works.


If you specify LOCAL, then there is no other method available, i.e.,


aaa authentication telnet console LOCAL


But, you can specify the fallback as LOCAL in the event your Radius/Tacacs server is not available,

aaa authentication telnet console LOCAL


HTH


Regards,

Prem


Please rate if it helps!

nobleton3366 Tue, 08/26/2008 - 06:44
User Badges:

I was afraid of that, but we can make it work. Thanks again.

jjoseph01 Thu, 08/28/2008 - 07:33
User Badges:

I forgot to rate this, so came back to do so. Thanks for all your help.

Actions

This Discussion