MGCP PRI issue.

Unanswered Question
Aug 24th, 2008

Hi all,

I have a 2811 with a VWIC-2MFT-T1 which I have configured as MGCP controlled gateway.

I recently upgraded the ISO to c2800nm-adventerprisek9_ivs_li-mz.124-20.T.bin. Since the upgrade my PRI never comes up in MGCP mode. It is always in TEI_ASSIGNED state. It works fine in H323 mode when the router is in fallback state.

Are the commands different for the PRI in this version of ISO? Any help is greatly appreciated.

I am attaching a small doc with the relevant configurations. Please let me know if more information is needed.

Thanks in advance.

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
ShailendraK Mon, 08/25/2008 - 01:42

Hi,

Thanks for the reply. I have attached the output. Because the PRI is flapping up and down, the output is a bit verbose.

Thanks.

Attachment: 
pcameron Mon, 08/25/2008 - 04:18

Always use the 'network-clock-select 1 t1 0/1/0' command to ensure the system is synchronised to the clock reference coming in from the Telco. Without this command you will be seeing clock slips on the T1, and this will cause D channel errors.

Secondly, remove the 'service mgcpapp' off the POTS dial peer. The MGCP operation is controlled via the T1 controller and the D channel commands. Service MGCPAPP under the POTS dial peer should NOT be used for any ISDN interface.

Thirdly, this is is a fractional t1, so you would need to busyout the unused B channels under the CCM service parameters, otherwise the CCM will attempt to used these B channels for outgoing calls.

refer here for some more details on MGCP operation -

http://www.cisco.com/en/US/tech/tk1077/technologies_configuration_example09186a00801ad22f.shtml

rob.huffman Mon, 08/25/2008 - 05:07

Hi Paul,

Very helpful answer here! +5 points for this and for your participation here in general :)

Take care,

Rob

ShailendraK Mon, 08/25/2008 - 06:51

Hi Paul,

Thanks for taking the time to reply. I tried all you advised but it is not helping at all. I have installed a different T1 card but it is the same. The router keep on flapping between registered and unregistered. The T1 has also not changed a bit.

Thanks.

cg100668 Wed, 08/27/2008 - 03:43

Hi, try removing the command " isdn bind-l3 ccm-manager" under the serial interface. Connect the ISDN line to register and put back the command under the serial interface. I have come across such a situation in some sites. Just sharing my experience.

Chandrasen

asandborgh Wed, 08/27/2008 - 06:45

How long is your hostname/domain name combination? Although the Cisco stated max length is 50 characters (concatenated) we had problems recently with 12.4(15)T with names that were longer than 43 characters. Once we shortened the names to that 43 or below the PRIs came right up. The TAC engineer told us the fix was ccm-manager config, but I have had problems before with that command in production, so I would be careful.

Hope this Helps and good luck

HYE WILSON Mon, 12/01/2008 - 12:18

Can these two commands, network-clock-participate and select be used with a 3800 router?

I have a T3 in the same router for MPLS. Will there be any impact on T3 clocking if I use these two commands?

TIA.

HYW.

asandborgh Wed, 08/27/2008 - 08:39

You might want to run debug ccm backhaul events and/or debug ccm backhaul packets and post the captures. Many times these debugs give you an idea of why the L3 backhaul is not working and that appears to be the problem since your circuit comes up with H323

richard.gu Wed, 08/27/2008 - 09:33

It looks like the PRI is not registered to the CCM. Can you check the endpoint at CCM and also do a debug mgcp packet on the router?

ShailendraK Wed, 08/27/2008 - 12:35

Hi,

Thank you very much . I have tried all the above suggestions. I am afraid nothing has changed.

I am attaching the output of the debugs after I have made the above changes and reloaded the router.

The debug are not make sense to me. I will appreciate any suggestions and expert advice.

Thanks again to everyone.

Regards.

Attachment: 
asandborgh Wed, 08/27/2008 - 13:22

Ok let's try something a bit different - first make sure you have the b-channels busied out in CCM service parameters (Advanced buttton then go to "Change B-Channel Maintenance Status 1:") as mentioned in an earlier post.

Next put in:

ccm-manager config server

ccm-manager config

no mgcp (wait 60 seconds)

mgcp

reset the gateway in CCM and wait for three minutes

if the PRI comes up do:

no ccm-manager config

What version of CCM are you running?

ShailendraK Wed, 08/27/2008 - 20:40

Thanks for replying. I tried that before this post. It doesn't work. After that I deleted the configuration, reloaded the router and did the present configuration.

I have CCM 4.1(3), sr7.

Thanks again.

richard.gu Thu, 08/28/2008 - 08:09

To me it looks like a IOS bug. From the MGCP point of view, the registration is complete successfully. But the IOS still not allow to bring the q921 up. Have you tried other IOS with the same configuration?

ShailendraK Thu, 08/28/2008 - 08:59

Thanks for replying.

It was working with the previous IOS. I upgraded and ran into this problem. The upgrade was because of a feature I needed. Before trying a different IOS I thought I would give the forum a try. I can try to change the IOS and post the result.

Thanks again.

ShailendraK Mon, 09/01/2008 - 12:06

Hi,

I does look as if it is a bug. As soon as I changed the image it started working with the same configuration.

The image I have now is c2800nm-adventerprisek9-mz.124-20.T.bin.

Thank you everyone who tried to help and hope my experience helps others.

Regards.

Actions

This Discussion