Routing

Unanswered Question
Aug 24th, 2008

s1(BGP) s1 (eirgp) s0(eirgp) e0

---->>RouterA<<---------------->>RouterB<<----------

I connected one interface BGP and another interface is eirgp,

am unable to ping the router Ethernet from routerA after configuring the redistribute bgp 65003

Router A

interface Loopback0

ip address 10.1.1.2 255.255.255.0

!

interface FastEthernet0

ip address 10.254.9.40 255.255.255.0

speed auto

!

interface Serial0

description PE30-AIRTEL-NOC [192.168.30.1/24]

ip address 192.168.30.2 255.255.255.0

encapsulation frame-relay

frame-relay interface-dlci 100

frame-relay lmi-type ansi

!

interface Serial1

description CE50-AIRTEL-HYD [10.20.30.2/29] [This serial connected to CE50-AIRTEL-HYD setial0/0/0]

ip address 10.20.30.1 255.255.255.248

!

interface Serial2

description CE60-AIRTEL-KOLKATTA [172.26.8.2/30]

ip address 172.26.8.1 255.255.255.252

!

router eigrp 100

redistribute bgp 65003

network 10.20.30.0 0.0.0.7

auto-summary

!

router bgp 65003

no synchronization

bgp log-neighbor-changes

network 10.1.1.0 mask 255.255.255.0

network 10.254.9.0 mask 255.255.255.0

redistribute eigrp 100

neighbor 192.168.30.1 remote-as 65003

auto-summary

ROUTER B

interface FastEthernet0/0

ip address 192.168.100.1 255.255.255.0

speed auto

full-duplex

no mop enabled

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface Serial0/0/0

description PE40-AIRTEL-NOC [10.20.30.2/29] [This serial connected to PE40-AIRTEL-NOC serial 1]

ip address 10.20.30.2 255.255.255.248

!

router eigrp 100

redistribute connected

network 10.20.30.0 0.0.0.7

network 192.168.100.0

auto-summary

!

!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Jon Marshall Sun, 08/24/2008 - 20:50

It's not entirely clear what you are trying to ping and from where but one obvious issue with the config on router A is that under your eigrp configuation you need to supply metric values when you redistribute BGP routes into EIGRP eg.

router eigrp 100

redistribute bgp 65003 metric 10000 1 255 10 1500

Can you update config and retest.

Jon

Actions

This Discussion