Internet connection load balancing on multiple Links

Unanswered Question
Aug 24th, 2008
User Badges:

Guys, I have a 3600 router where I have 2 internet links. Is it possible to do load sharing for both outbound and inbound traffic. i have a public ip pool for Natting..


Thanks in advance..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
spremkumar Sun, 08/24/2008 - 21:29
User Badges:
  • Red, 2250 points or more

Hi Harish


You need to provide more details on the following :


Internet links subscribed from same ISP or from different ISP


Public ip pool provided by the ISP/ISPs or your own ip pool


regds


harish.ab Sun, 08/24/2008 - 21:31
User Badges:

Internet connections are from different ISP's


and the IP pool we have got from both ISP's.. if it is required we are ready to take our own IP's.

Marwan ALshawi Sun, 08/24/2008 - 22:02
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

are using BGP with your ISP?

spremkumar Sun, 08/24/2008 - 22:41
User Badges:
  • Red, 2250 points or more

Hi Harish


Can you try this and revert ???


ip nat pool ISP1 a.a.a.0 a.a.a.b netmask x.x.x.x

ip nat pool ISP2 c.c.c.0 c.c.c.d netmask y.y.y.y

!

ip nat inside source route-map map1 pool ISP1

ip nat inside source route-map map2 pool ISP2

!

route-map map1 permit 10

match ip address subnet1

set ip next-hop ISP1

set ip next-hop ISP2

!

route-map map1 permit 20

match ip address subnet2

set ip next-hop ISP2

set ip next-hop ISP1

!


regds


harish.ab Sun, 08/24/2008 - 22:47
User Badges:

thanks.. as per this.. it would take isp2 only if isp1 fails rite..? and more over I have only one subnet and if i do per souce load balancing , we cant acheive correct load balancing rite.. like if a source is using more bandwith, it always take same path..?

Marwan ALshawi Mon, 08/25/2008 - 00:58
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

hi Harish


try the following



lets say u have the following subnet

192.168.1.0/24

u can devide it to two subnets for loadsaharing


192.168.1.0/128

192.168.1.127/128


acccess-list 101 permit ip 192.168.1.0 0.0.0.128 any

acccess-list 102 permit ip 192.168.1.127 0.0.0.128 any


access-list 100 pemirt ip any any


then


ip nat pool ISP1 a.a.a.0 a.a.a.b netmask x.x.x.x

ip nat pool ISP2 c.c.c.0 c.c.c.d netmask y.y.y.y



route-map isp permit 10

match ip address 101

set ip next-hop ips1

!

route-map isp permit 20

match ip address 102

set ip next-hop ips2



route-map isp permit 30

match ip address 101

set ip next-hop ips2

!

route-map isp permit 40

match ip address 102

set ip next-hop ips1



ip nat inside source list 100 pool ISP1

ip nat inside source list 100 pool ISP2


apply the route map to the router interface that connect to ur LAN


and let me know


good luck


if helpful Rate

Marwan ALshawi Sun, 08/24/2008 - 22:54
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

hi Edwin


based on ur route map applied to nating lane

if the packet come from subnet one will match the line one nating statment and will use the orue map and go to the ISP1


if ISP1 down

how will will this line handel this issue??

u put the next line as ISP while the pool will be ISP1 pool !!!


if we make like

access-list 100 permit ip any any



route-map map1 permit 10

match ip address subnet1

set ip next-hop ISP1

set ip next-hop ISP2



route-map map1 permit 20

match ip address subnet2

set ip next-hop ISP2

set ip next-hop ISP1

then


ip nat pool ISP1 a.a.a.0 a.a.a.b netmask x.x.x.x

ip nat pool ISP2 c.c.c.0 c.c.c.d netmask y.y.y.y



ip nat inside source list 100 pool ISP1

ip nat inside source list 100 pool ISP2



and we apply the route map to the source or sources interfaces

so the distination dicision will be taken first then will be send to the corsponding NAT

Thank you


spremkumar Sun, 08/24/2008 - 23:51
User Badges:
  • Red, 2250 points or more

Hi marwanshawi


Thx for pointing me out.


regds



Marwan ALshawi Mon, 08/25/2008 - 00:08
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

u welcome :)

Actions

This Discussion