Fax issues with 2811 Voice Gateway

Answered Question
Aug 25th, 2008

Here's our fax setup:

PSTN -> 2811 Voice Gateway -> 3560 switch -> ATA186 -> RightFax Fax Server

I'd say 95% of our faxes are received error free. However, there's always a handfull every day that error out. The debug on our fax server shows me this error:

(Hangup: T.30 T2 timeout, expected page received. (77)) in BfvFaxEndReception

I contacted the manufacturer of our fax server (the analog boards) and they said this probably is because we're not using the T.38 protocol on our gateway. We could use it, but we have the ATA186's in there that do not support the protocol.

Here's my dial-peer that sends the incoming fax to the ata's and on to the fax server:

!

voice class codec 1

codec preference 1 g711ulaw

!

dial-peer voice 200 voip

preference 1

destination-pattern 8...

progress_ind setup enable 3

voice-class codec 1

voice-class h323 1

session target ipv4:172.16.1.2

incoming called-number .

dtmf-relay h245-alphanumeric

fax-relay ecm disable

fax rate disable

ip qos dscp cs5 media

no vad

Is there any better way I can configure this gateway to help with the T.30 error's maybe?

I have this problem too.
0 votes
Correct Answer by Michael Hanes about 8 years 3 months ago

The T2 timer is an approximately 6 second T.30 command message timeout. I cannot think of anything from a configuration point of view that would resolve a problem involving this amount of delay. However, I do have some general recommendations for your gateway configuration -

- You should configure the dial-peer for NSE-based passthrough using the command " modem passthrough nse codec g711ulaw". In addition to enforcing the G.711 codec, changes are made to other DSP functions in order to better transport fax transmissions. You can also have this configured globally under "voice service voip" but I am assuming that it is not since it was not shown in your config snippet.

- You can remove the command "fax-relay ecm disable" as this command is only functional when you are using Cisco fax relay or T.38 fax relay. Leaving this command in place will not cause an issue for you but removing it will give you a bit of a cleaner config.

Regards,

David

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Michael Hanes Tue, 08/26/2008 - 10:09

The T2 timer is an approximately 6 second T.30 command message timeout. I cannot think of anything from a configuration point of view that would resolve a problem involving this amount of delay. However, I do have some general recommendations for your gateway configuration -

- You should configure the dial-peer for NSE-based passthrough using the command " modem passthrough nse codec g711ulaw". In addition to enforcing the G.711 codec, changes are made to other DSP functions in order to better transport fax transmissions. You can also have this configured globally under "voice service voip" but I am assuming that it is not since it was not shown in your config snippet.

- You can remove the command "fax-relay ecm disable" as this command is only functional when you are using Cisco fax relay or T.38 fax relay. Leaving this command in place will not cause an issue for you but removing it will give you a bit of a cleaner config.

Regards,

David

snooter Tue, 08/26/2008 - 10:17

Thank you very much for the information..

Your comment "In addition to enforcing the G.711 codec, changes are made to other DSP functions in order to better transport fax transmissions." - does this mean I need to further make changes to the dsp's or is this already done by the modem passthrough command?

Michael Hanes Tue, 08/26/2008 - 11:12

These other changes (such as VAD disablement, playout buffer changes, etc.) occur automatically when the "modem passthrough" command is configured and a fax call is detected. You do not have to make any additional configuration changes on the voice gateway itself.

Regards,

David

Actions

This Discussion