CVP Record Step Max File Size

Unanswered Question
Aug 26th, 2008
User Badges:
  • Silver, 250 points or more

All,


I am having a problem where the max I can record is 32 seconds or a total file size of 256000 bytes. At this point it cuts me off and makes me stop recording. My max_record_time in cvp record step is set for 180 default. In the CVP logs I see this..



10.1.61.40.1219784559607.25.Recording,08/26/2008 14:02:39.919,Record_01,interaction,audio_group,initial_audio_group

10.1.61.40.1219784559607.25.Recording,08/26/2008 14:03:23.029,Record_01,data,duration,32000

10.1.61.40.1219784559607.25.Recording,08/26/2008 14:03:23.029,Record_01,data,size,256000

10.1.61.40.1219784559607.25.Recording,08/26/2008 14:03:23.029,Record_01,data,maxtime,false

10.1.61.40.1219784559607.25.Recording,08/26/2008 14:03:23.029,Record_01,data,filename,14257863.wav

10.1.61.40.1219784559607.25.Recording,08/26/2008 14:03:23.029,Record_01,data,filepath,C:\Cisco\CVP\VXMLServer\Tomcat\webapps\CVP\recordings\14257863.wav

10.1.61.40.1219784559607.25.Recording,08/26/2008 14:03:23.029,Record_01,exit,done



what setting where would be causing this to cut off at 32 secs / 256 max file size... some apache settings?



Chad

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (6 ratings)
Loading.

>some apache settings


Possibly a gateway setting. I speculate that the recording would be first made on the gateway, and then sent through Tomcat to the file you have named.


One thing to do is to turn on detailed debugging on the server and check that the VXML that Audium generates has "maxtime" set to what you think it should be - 180s in your case.


finalsilence="4000ms" dtmfterm="true" type="audio/x-wav">

Record a message after the beep.

I didn't hear anything, please try again.


If maxtime is not set it defaults to a "platform-specific value" - the platform being the IOS voice browser.


Any weird settings for finalsilence?


Chad, have a quick read of the VXML standard on the record step. (section 2.3.6)


http://www.w3.org/TR/voicexml20/#dml2.3.6



Regards,

Geoff


Chad Stachowicz Mon, 09/01/2008 - 20:14
User Badges:
  • Silver, 250 points or more

Geoff,


I have done application debugging and it's clear what the issue is. It sets the max file size to 256000 and thats 32 seconds apparently. It seems to set it somewhere in CVP but its not on the application itself. I checked the IVR service but also to no avail. maxtime is set to 180 and final silence is set to 4 secs. I need someway to change the max file size but I have a feeling its a limitation of IOS..



Thanks,

Chad

Chuck Smith Fri, 10/31/2008 - 12:03
User Badges:

ivr record memory session XXXX


this is in kilobytes on the VXML gateway. the equals to prompts up to 256 megabytes. That is a big prompt. Should be plenty for what you want to do.

Chad Stachowicz Fri, 10/31/2008 - 17:57
User Badges:
  • Silver, 250 points or more

I am guessing that the ivr record default is 256kb? This is an awesome answer, +5!!!


Chad

Chuck Smith Fri, 10/31/2008 - 18:33
User Badges:

Not really sure if you are being sarcastic or not. You can thank me tomorrow when your ivr prompts go past 32 seconds.


The default setting is 256K The maximum is 256,000K. That is 256 Megabyte uLaw file. That is huge.


A CCITT uLaw file of 256k is 32 seconds long. If you bumped up the ivr record memory session 256000 you would get more record time then you would EVER need for a prompt. You need to keep this in the limits of the RAM on the IOS gateway though. You could crash the gateway if a VXML session got stuck in the recording state and ate up all the memory free in RAM.


There are 2 settings that affect the recording time on the VXML browser on the IOS gateway.


ivr record memory system

ivr record memory session


ivr record memory system is defaulted to 256,000k. This is across all sessions.

ivr record memory session is defaulted to 256k. This is a per call setting.


Chad Stachowicz Sun, 11/02/2008 - 01:13
User Badges:
  • Silver, 250 points or more

I was not being sarcastic, that really is awesome, thats been an issue of mine for months!


Bravo mate ;)


Chad

Chuck Smith Sun, 11/02/2008 - 12:49
User Badges:

WOW you guys just doubled my votes on the forums. Thanks hahaha.


This is fun I should read these more often.



syedfurqan.ahmed Mon, 04/21/2014 - 05:53
User Badges:

 

 

Dear All,

 

 I am also facing the same issue i have reset the value of ivr record  memory session on VXML Gateway to 256000 . i am using Cisco AS5350XM (BCM) processor (revision 0x22) with 393215K/131072K bytes of memory. can someone help please

Actions

This Discussion