Inter VLAN routing

Unanswered Question
Aug 26th, 2008

Hi

I am new to CISCO. Please guide me how to do inter vLAN routing. Please tell me along with command

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shane.kearney Mon, 09/08/2008 - 05:14

ok here is the low down on intervlan routing.

you have 2 VLANs lets call then sales and IT they are both connected to the same router lets say E0(Sales) and E1 (IT)

the ip on sales is 192.168.1.1 and on IT is 192.168.2.2, it goes like this

Vlan database

vlan 10

vlan 10 name Sales

vlan 20

valn 20 name IT

exit

config t

int FA0/1

switchport access vlan 10

int FA0/2

switchport access vlan 20

move to the router now and issue these cmds

config t

int fa0/0.1

encapsulation dot1Q 10

ip address 192.168.1.1 255.255.255.0

no shut

Interface Fa0/0.2

encapsulation dot1Q 20

ip address 192.168.2.1 255.255.255.0

no shut

now back to the switch and the interface that connects the switch to the router, lets call it Fa0/3 issue this command

Int FA0/3

switchport mode Trunk

and now it works!!

HTH

matthewt1501 Thu, 09/11/2008 - 05:18

Thats an open ended question my friend.

Do you a have a Router, or MSFC Card?

As you need at least some routing capabilities to communicate between VLANS....

There are a few topologies you can create... the best thing is to tell us what you have, and how it's set-up.

Failing that search for Inter-VLAN Routing on this site, and there are more that enough resources here!

Cheers.

Matt

Actions

This Discussion