802.1P in inner Vlan

Unanswered Question
Aug 26th, 2008

Hello,

i have QinQ tunnel, is it possible to set user priority (CoS) in inner vlan?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Mon, 09/01/2008 - 09:21

Hello Elena,

the answer is yes on C6500 with 12.2SX

see

http://www.cisco.com/en/US/docs/ios/qos/command/reference/qos_s1.html#wp1012910

set cos-inner cos

To copy the outer COS to the inner COS for double-tagged packets, use the set cos-inner cos command in policy-map class configuration mode. To remove the outer COS copied to the inner COS for double-tagged packets, use the no form of this command.

set cos-inner cos cos-value

no set cos-inner cos cos-value

inside a policy-map

Hope to help

Giuseppe

elena.rus Tue, 09/02/2008 - 14:59

Thanks for your help, but we have't C6500, just only C3550

May be exist another solution.

Cisco2851--------switches-------C3550

Cisco2851:

interface GigabitEthernet0/0.10

encapsulation dot1Q 10 second-dot1q 2-50

pppoe enable group global

C3550:

interface FastEthernet0/2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 10

switchport mode trunk

interface FastEthernet0/3

switchport access vlan 10

switchport mode dot1q-tunnel

We want to set CoS in inner (user) vlan tag, 2-20 must have one CoS and 21-50 - another, because the next device after C3550 don't understand vlan, but can

classify traffic by user priority (cos).

Now We are using dot1q-tunnel to hide inner (users) vlans. Is it possible to use something insted of dot1q-tunnel for set CoS on users vlans?

Giuseppe Larosa Wed, 09/03/2008 - 13:37

Hello Elena,

>>Now We are using dot1q-tunnel to hide inner (users) vlans. Is it possible to use something insted of dot1q-tunnel for set CoS on users vlans?

the Catalyst 3550 should be able to do that: setting CoS 802.1p field on an outgoing trunk port should be possible.

If you want to mark based on Vlan-id you can do it by using an IP ACL: Vlan X means source ip address that of subnet A associated to vlan X.

You can classify IP traffic by using IP standard or IP extended ACLs; you can classify non-IP traffic by using Layer 2 MAC ACLs.

see

http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.2_25_sec/configuration/guide/swqos.html#wp1044742

You should be able to use the modular QoS with class-map for marking on the ingress interface.

Hope to help

Giuseppe

Actions

This Discussion