Redundancy of two links with a dynamic routing protocol

Unanswered Question
Aug 27th, 2008
User Badges:

Hi,

I have two sites linked by two LAN-to-LAN links.


The first LAN-to-LAN is a 34Mbps. The second is a 12Mbps one


Im using static routes on both routers to use only the 34Mbps link, because if I load the sharing per-packet on the interfaces, some applications doesn't work properly.


And, if the 34Mbps goes down, I have to change the static routes to use the 12Mbps link.


What I want is to configure a dynamic routing protocol to converge the traffic to the 12Mbps automatically.


Please, check the attachemt.

Is this possible in this desing?


Or, what should I do to improve the situation..


Thanks


Tauer



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Marwan ALshawi Wed, 08/27/2008 - 04:28
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

try this first


router on LAN 1

ip route 172.16.0.0 255.255.255.0 [the next hop ip on the 34M link]


ip route 172.16.0.0 255.255.255.0 [the next hop ip on the 12M link] 10


look at the 10 at the end

this will increase the route metric

so the first route will be used if the 34M link is down then the router will use the second route which is through the 12M link


the same idea do it on the other side router


good luck


if helpful Rate

Tauer Drumond Wed, 08/27/2008 - 04:34
User Badges:

Hi marwanshawi,

Im using this configuration right now.


But the question is that the two links are a LAN-to-LAN.


Because of this, the router doesn't "understand" that a route is unreacheable.


So, this configuration doesn't work in my scenario.


Another sugestion?


Thanks

Not sure if my previous response made it but here's another try:


Try this:


ip route 172.16.0.0 255.255.255.0 [34M interface] [next-hop of 34M interface]

ip route 172.16.0.0 255.255.255.0 [12M interface] [next-hop of 12M interface] 250


As far as I know, the static route will get installed if it only sees the next-hop route coming from its specified interface.


Hope that helps.

Tauer Drumond Wed, 08/27/2008 - 07:07
User Badges:

Hi,

this kind of configuration still doesn't work.


I'd like to try an OSPF configuration..


Any sugestion?


Thanks


Tauer

Marwan ALshawi Wed, 08/27/2008 - 15:55
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

ok

i will give this example

LAN1 192.168.0.0/24

router1 34M int: 10.1.1.1/24

router1 12M int: 20.1.1.1/24


LAN2 172.16.0.0/24

router2 34M int: 10.1.1.2/24

router2 12M int: 20.1.1.2/24



Router1 config


router ospf 1

network 10.1.1.0 0.0.0.255 area 0

network 20.1.1.0 0.0.0.255 area 0

network 192.168.0.0 0.0.0.255 area 0


now we gonna configure the ospf cost of both interfaces between the routers manuly to influance the ospf path selection


the lower the prefered

do this on each interface on each router the same



interface [34M int]

ip ospf cost 10


interface [12M int]

ip ospf cost 150




Router2


router ospf 1

network 10.1.1.0 0.0.0.255 area 0

network 20.1.1.0 0.0.0.255 area 0

network 172.16.0.0 0.0.0.255 area 0



now on the interface level on router2 as what we have done on router1


interface [34M int]

ip ospf cost 10


interface [12M int]

ip ospf cost 150



in this case the router will chse the lower interface cost

once the interface with lower cost gos down the other will take over


good luck


please, if helpful Rate


Tauer Drumond Thu, 08/28/2008 - 03:20
User Badges:

Hi marwanshawi,

The problem with a LAN-to-LAN link is that the interface never goes down...


And when a circuit is down, the router doesn't realize this, because the interface still continuous UP and receiving sinalization from DM16E1...


But...with this configuration you sent me, the router can realize else the interface is still UP?


Thanks


Tauer

Marwan ALshawi Thu, 08/28/2008 - 04:36
User Badges:
  • Purple, 4500 points or more
  • Community Spotlight Award,

    Best Publication, December 2015

its ok

even if the interface up but the route will not apear as it will not come from the primary interface then will use the second one

based on the ospf cost


try it and if helpful rate

Tauer Drumond Thu, 08/28/2008 - 04:56
User Badges:

Hi marwanshawi,

I cant do test right now, but ill schedule the change later.

Anyway, I post here the results...


Thanks a lot.


Tauer

bbaillie Thu, 08/28/2008 - 05:00
User Badges:
  • Bronze, 100 points or more

The links are 34M and 12M that's almost a 3 to one ratio and a kind of waste whenthe 12 meg is idle until afailure occurs. EIGRP is Cisco's favored routing protocol and provides unequal cost load balancing, which means it can take advantage of both pipes and of course keep working when one path fails. The failover is immediate for interface down and 15 seconds for loss of adjacency (more likely you will see a loss of adjacency, carrier equipment most times will keep the interface up, thus making static routes a big problem)


http://www.cisco.com/en/US/tech/tk365/technologies_tech_note09186a008009437d.shtml


Even better than that is Cisco's newer feature for Cisco express forwarding to distribute traffic further by including the destination address and the port number in the path selection decision. This is a 12.4 T train feature which I suspect will be mainline very soon because it works great.


http://www.cisco.com/en/US/docs/ios/ipswitch/configuration/guide/cef_load_balancng.html


Cheers,


Brian

Actions

This Discussion