Registration Rejected Error DBConfig

Unanswered Question
Aug 27th, 2008
User Badges:

Hello,


I am getting the error "Registration Rejected Error DBConfig" when trying to register IP phones or communicator with Call Manager 4.1(3). The Call Manager was working fine earlier and we had no problems and one fine day it just stopped accepting phone registrations. We even deleted some phones from Call Manager to check if we are exceeding the number of phones allowed. Even those phones are unable to register now.


I have checked that Auto register option is enabled. Even if I try to manually add the phones even then it gives some transaction error!!Please help. We are badly stuck.


Thanks & Regards,

Siddharth

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
dezoconnor Wed, 08/27/2008 - 04:52
User Badges:
  • Silver, 250 points or more

Hi Siddharth, maybe a corrupt database. Run the DBLhelper tool which will check the database and fix if needed.

Rob Huffman Wed, 08/27/2008 - 05:22
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Siddharth,


Just to build upon the great thinking from my friend Darren (+5 points here Dez :)


Troubleshooting Cisco IP Phone Registration Problems with Cisco CallManager 3.x and 4.x


http://www.cisco.com/en/US/products/hw/phones/ps379/products_tech_note09186a008009485a.shtml



Using DBLHelper to Reestablish a Broken Cisco CallManager Cluster SQL Subscription


http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00801e7ddf.shtml



Hope this helps!

Rob

siddharthsukhija Wed, 08/27/2008 - 07:16
User Badges:

Hi,


Thanks a lot to you for ur concerns. I read the whole doc for troubleshooting ip phones and also tried all of the stuff mentioned there. tried generating the SEP*.cnf.xml files. Copied it for new device and renamed it also. When trying to manually add that it still gave the samme error message:(


What we have is a single Call Manager. We recieved that in properly installed from one of the other teams in our company. It's name is CCMSubscriber but as per I understand it is working as a publisher only.


Any issues here? As per the DBHelper tool is concerned, I cant find it on our server!!


Plz help.


Thanks & Regards,

Siddharth Sukhija

Ayodeji Okanlawon Wed, 08/27/2008 - 07:42
User Badges:
  • Super Bronze, 10000 points or more
  • Cisco Designated VIP,

    2017 IP Telephony

Siddharth,


In your case, you do not need the DBLhelper file as you only have one server. This tool is used to troubleshoot Database replication issues between the Pub and the subscribers.


I will suggest you try 2 things..


1. Restart the TFTP service on the server..

2. Restart CCM service.

3. Restart the server itself.

Rob Huffman Wed, 08/27/2008 - 07:51
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Siddharth,


Just to add onto the good info from Deji (+5 points my friend!)


Can you also try setting a Call Forward All from a working IP Phone. I am concerned that this actually is set up as a Subscriber server (not a Publisher). The inability to add phones and broken CFWDALL would be two symptoms of this issue.


Rob

siddharthsukhija Wed, 08/27/2008 - 07:49
User Badges:

This is what I am getting as an error when trying to manually add the phone


Error Information

Distributed transaction completed. Either enlist this session in a new transaction or the NULL transaction (74)


Details:

Error No. -2147219894 (0x8004064a):

CDBLException Dump: [Distributed transaction completed. Either enlist this session in a new transaction or the NULL transaction]


Microsoft has an article

http://support.microsoft.com/kb/834849


that says something about the kind of error I am getting. I have found the file Instcat on my server also. Don't know if it is safe to follow the give procedure. Please Guide.


Also to add on we also installed IPCC Express on the same call manager server to which we could not specify the license. Can it also be related to this b'cos this we have seen this only after we installed IPCC??


Thanks & Regards,

Siddharth

shabali52 Wed, 08/27/2008 - 07:47
User Badges:

You might want to pull up the Unassigned DNs from Route Plan report and delete them all, this is completely safe to do in production and try adding the phone again, I think your phone registration are maxed out.

siddharthsukhija Wed, 08/27/2008 - 21:54
User Badges:

Hi,


Tried deleting Unassigned DN's but to no avail. Tried restarting the server also but still not able to add the server. I guess it might be a DB issue but dont know how to resolve it!!


Anything else that I might try?


Thanks & Regards,

Siddharth

siddharthsukhija Thu, 08/28/2008 - 07:03
User Badges:

Hi,


Got the solution!!!


A trigger related to device table consisted of access to entry named 'asd'. Had to comment entry that and phones started registering!!


Wolllaaaa!!!


Thanks all for your support:)


Thanks & Regards,

Siddharth Sukhija

jbarcena Thu, 08/28/2008 - 07:27
User Badges:
  • Red, 2250 points or more

5 points for posting the solution.

kanbaycco Tue, 02/03/2009 - 07:27
User Badges:

Dear Sids,


I am also facing simalar problem can you please let me know exact setting.


Thanks

Rahul

Actions

This Discussion