3845 - GE- SFP interface not recoving after upgrade

Unanswered Question

I upgraded a few 3845's from 12.4(12) to 12.4(15)T5. A few upgrades show that the Gig0/0 interface that has a LX SFP in it does not come up. Regardless if you bounce or reseat. We downgraded the code back to the original and the link comes up. Can't find any bugs, and cases have not proven to be successful. You do see log messages of the GBIC being inserted and removed. I have found some doc on cisco being stricter on the supported SFP's. Has anyone seen similar issues? Even seen this on 3750 switches.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Danilo Dy Thu, 08/28/2008 - 01:46
User Badges:
  • Blue, 1500 points or more

Did you try without the "T" (or New Features/Hardware Support)?


If you just need to fix some bugs/vulnerabilities you don't need the "T".


Although the "T" also fix some bugs/vulnerabilities but it added New Features/Hardware Support and this may introduce new bug/vulnerability and/or incompatibility - since it is created by humans.


See this link for more info about migration strategy http://www.cisco.com/warp/public/620/1.html

The reason for this upgrade is we have requirements to support new features and hardware that require the T train code. Can anyone find an issue with unsupported SFP's in the T train code where the unsupported SFP's worked in 12.4(12) mainline? The only thing I can find is that in these instances we are using unsupported SFP's.

gheimgartner Wed, 11/19/2008 - 09:56
User Badges:

I'm sure you have figured this out by now, however I did come across your post today. And we ran accross this after a 3750 upgrade. We were using 3rd party SFP's and the vendor had coded them with the same serial number. The new image recognized that and they wouldn't work (However they worked fine prior to the upgrade)

Actions

This Discussion