LMS 3.0.1 - CiscoView not recognizing some devices

Unanswered Question
Aug 28th, 2008

Hi guys,

There are some devices that are not been recognized by CiscoView. When I try to open ChassiView for these devices it comes up with an error regarding not having the device package. I am using LMS 3.0.1 with CiscoView 6.1.7.

The device models that are not recognized are:

- Cisco 3845 Integrated Services Router

- Cisco 2811 Integrated Services Router

- Cisco 2501 Router

- Cisco Catalyst 2960G-24TC Switch

- Cisco Catalyst 1924 A Switch

I checked http://www.cisco.com/cgi-bin/Software/CiscoView/cvplanner.cgi and, for Cisco Catalyst 1924 A Switch, for instance, I got 3 files there: Cat1900.cv50.v3-0, nmidb.1.0.089 and StackMaker.cv50.v2-1.

Do I need to install all these 3 files for 1924 and all files I got there for other models? Is it normal CiscoView not recognizing some devices like these one listed?

Thank you,


Flaviano Leoncini.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Martin Ermel Thu, 08/28/2008 - 07:05

you need to download all three files and put them togehter in one directory along with the files you get for the other devices (you need nmidb.* only once).

Then go to Common Service > Software Center > Device Update

select CiscoView > Check for updates and install the device packages from the filesystem

Or select Cisco.com instead ..

...if your LMS Server is properly configured and can connect to the internet. Then you also can download the needed packages directly from CCO through the GUI (which is much more comfortable).

This is absolutly normal behaviour. When LMS is shipped not all plattforms are supported by any module in LMS - this is the way to get the support for these devices.

flaviano.leoncini Thu, 08/28/2008 - 12:25

Hi Mermel, thank you for your answer.

I've tried to install the packages separately and I got the error below. This error is for 2500 package, but I got it for 2 other packages! Is there I should do to avoid this?

Number of Packages Selected for Install : 1

For Product(s) : CiscoView

Install Invoked by user : admin

The Package(s) Selected for Install :


Installation failed for product [CiscoView] with message : com.cisco.nm.xms.psu.packagemgmt.InstallerException: Repository in use. Another Package Support Updater client session may be modifying device support.

Thank you,



Martin Ermel Thu, 08/28/2008 - 13:36

this means that another psu job is running or was stopped ungracerfully.

stop the LMS processes with 'net stop crmdmgtd' in a DOS box. Remove the file


where NMSROOT is the installation directory (defaults to C:\Program Files\CSCOpx)

then restart the LMS processes with 'net start crmdmgtd'

and try it again

flaviano.leoncini Fri, 08/29/2008 - 09:49


I couldn't find the lock file you said.

When I try to run the update, either trying to install just one package or all of them at the same time, my browser points to "http://localhost:1741/cwhp/s0026.do" and I got a "The page cannot be displayed" message. When I check Sevices, the 'CiscoCowrks Daemon Manager' is up, but 'CiscoWorks Web Server' is down. After rebboting the server, I check the event log and this update I've just tryed to do is not logged there.

Whn I try yo install all packages at the same time, these are the packages listed for downloading:

Package Name Type Product Name Installed Version Available Version Readme Posted Date size

1. Cat1900 DevicePackage CiscoView 3.0 NA NA

2. Cat2960 DevicePackage CiscoView 5.0 NA NA

3. NGMARShare DevicePackage CiscoView 1.1 1.4 NA NA

4. Rtr2500 DevicePackage CiscoView 2.0 NA NA

5. Rtr2800 DevicePackage CiscoView 8.0 NA NA

6. Rtr3800 DevicePackage CiscoView 8.0 NA NA

What can be wrong? Is there another way to update, like via command line, for instance?

Thank you.




This Discussion