setup remote network using same subnet as host

Unanswered Question
Aug 28th, 2008
User Badges:

I have a simple network. My host is in 192.168.1.0 network. I have a T1 connect to my remote network that I assign 192.168.10.0; Due to some of my legacy device doesn't do routing. I need to put both my remote and host in the same subnet (192.168.1.0); What changes I need to make to make this to work? By the way, my T1 line is working (192.168.14.0). Help please!! I need this work quick. Thanks!!!


Host#sh run

Building configuration...


Current configuration : 3318 bytes

!

version 12.4

hostname Host

controller T1 0/0/0

framing esf

clock source line primary

linecode b8zs

channel-group 0 timeslots 1-24

description PSTN

!

interface FastEthernet0/0

description inside

ip address 192.168.1.254 255.255.255.0

duplex auto

speed auto

!

!

interface Serial0/0/0:0

description T1 to Remote

ip address 192.168.14.1 255.255.255.0

encapsulation ppp

!

router eigrp 10

network 192.168.1.0

network 192.168.14.0

auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.3

=====================


Remote#sh run

Building configuration...


Current configuration : 3318 bytes

!

version 12.4

hostname Remote

controller T1 0/0/0

framing esf

clock source line primary

linecode b8zs

channel-group 0 timeslots 1-24

description PSTN

!

interface FastEthernet0/0

description inside

ip address 192.168.10.254 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0/0:0

description T1 to Remote

ip address 192.168.14.2 255.255.255.0

encapsulation ppp

!

router eigrp 10

network 192.168.10.0

network 192.168.14.0

auto-summary

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.1.254

!

!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Thu, 08/28/2008 - 10:52
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Donald,


You need to configure transparent bridging:


http://www.cisco.com/en/US/docs/ios/bridging/configuration/guide/br_transprnt_brdg_ps6350_TSD_Products_Configuration_Guide_Chapter.html


basically, on both routers you execute:


bridge 1 protocol ieee


then remove the IP addresses on both WAN and LAN and assign bridge group 1 on those interfaces. IP Routing must be disabled and you need to keep in mind, you are extending your Layer2 broadcast domain over an unreliable and slow WAN link.


Please proceed with care.


I strongly recommend investigating how to make the legacy application work in a routed environment or replace the application altogether.


Bridging over the WAN is something to be avoided at all costs.


HTH,


__


Edison.


Please rate helpful posts


donlin123 Thu, 08/28/2008 - 11:07
User Badges:

There are two options that I can also try:


nat everything from 192.169.10.X network to 192.168.1.X


Or

USE IPSEC-VPN between two sites.


If I do Nat, what change I need to make? Thanks

Edison Ortiz Thu, 08/28/2008 - 11:12
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

NAT won't work as traffic originated in 192.168.1.x with destination to another 192.168.1.x will remain local and won't get to the router performing the NAT.


IPSec VPN does not allow you to bridge networks. A VPN is often created to connect networks in a secured manner, it's not designed to bridge networks.


HTH,


__


Edison.

Actions

This Discussion