Port-Channel Issue

Unanswered Question
Aug 28th, 2008

Greetings,


I am having a weird issue with a port-channel interface. I am configuring a trunking interface to link up a switch with a VMWare ESX Server virtual switch. I have set up the trunking on the virtual side as well as on my physical switch. I am using 2 ports to create this channel. The problem is when I set up a continous ping from my Windows system, and monitor I am seeing some interesting results. When I add both ports to the channel, communication stops. When I remove one, communication starts up again through the port not in the channel. When I shutdown the port channel for several mins and open it up again, the pings go on for about a min before timing out. I am not sure whats going on. The channel configs match the physical interface configs. I would assume the trunking is set up correctly since it does work when not in the channel. Any help would be appreciated.


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
bbinion80 Thu, 08/28/2008 - 11:41

Also...here are the configs from all interfaces.



Switch#show run int g1/44

Building configuration...


Current configuration : 289 bytes

interface GigabitEthernet1/44

description exstest3 (Po40 Member)

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 22

switchport trunk allowed vlan 20-22,220

switchport mode trunk

switchport nonegotiate

no cdp enable

spanning-tree portfast trunk

end


Switch#show run int gi2/1

Building configuration...


Current configuration : 288 bytes

!

interface GigabitEthernet2/1

description exstest3 (Po40 Member)

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 22

switchport trunk allowed vlan 20-22,220

switchport mode trunk

switchport nonegotiate

no cdp enable

spanning-tree portfast trunk

end


Switch#show run int po40

Building configuration...


Current configuration : 274 bytes

!

interface Port-channel40

description Trunk to ESXTest3

switchport

switchport trunk encapsulation dot1q

switchport trunk native vlan 22

switchport trunk allowed vlan 20-22,220

switchport mode trunk

switchport nonegotiate

shutdown

spanning-tree portfast trunk

end


Mark Yeates Thu, 08/28/2008 - 11:48

Brian,


You don't have the physical interfaces applied to the port channel. Try adding this to both interfaces Gi 1/44 and 2/1.


channel-group 40 mode on


HTH,

Mark


*Don't forget to do a "no shut" on int po40*

bbinion80 Thu, 08/28/2008 - 11:52

My apologies, to get the link up and working, I removed them. But when I had it set up, I did have the "channel-group 40 mode on" command applied to the two physical ports.

Mark Yeates Thu, 08/28/2008 - 12:04

The interface configs look fine. Have you configured and verified the port channel on the server is configured properly?

bbinion80 Fri, 08/29/2008 - 04:34

Well we teamed the NIC's using the VM software. The team appears to be working fine. As I said, the port channel is the issue because when I pulled the ports our of the channel, the links come up with no problem. That leads me to believe the configuration is set up correctly. I am hoping that maybe I am missing something small but I am clueless.

shastymacnasty Fri, 08/29/2008 - 04:53

hey brian, try various load-balancing options on the ESX side, I have had issues in the past with port-channels connected to ESX machines, go into the VMNics properties using the GUI and try load balancing using IP-source-destination or something along those lines, havent looked at it for awhile!

good luck

Actions

This Discussion