Long distance dial issue

Unanswered Question
Aug 28th, 2008

one of our remote sites can't dial valid 509 number which worked on other sites.

Debug isdn q931 and we got:

Cause i = 0x8081 - Unallocated/unassigned number

Any idear what's going on? Thanks.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.3 (6 ratings)
Loading.
jbarcena Thu, 08/28/2008 - 12:48

Is the problem happenig with all the phones or just a few of them?

Could you please upload a CCM detailed trace with matching debug isdn 1931, debug h225 asn1, debug h245 asn1?

Please include complete debugs.

shabali52 Thu, 08/28/2008 - 12:52

This is most likely an issue with CSS, make sure that the gateway and phone CSS has access to a route pattern that can dial long distance numbers.

Jaime Valencia Thu, 08/28/2008 - 13:13

it cannot be related to CSS if the call is hitting the GW, that by itself means the call did reached the right route pattern and was routed to the GW.

That code means that the telco is unable to match any phone number. do you have the same telco on all sites?

are you stripping the dial code? 9? it sounds to me like you're sending extra digits or less digits than you should

HTH

java

if this helps, please rate

learnerkang Thu, 08/28/2008 - 13:18

Here is output for debug isdn q931:

Aug 27 15:44:33.592 PST: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0xD is 0x0 0x1, Calling num 613XXXXXXX

Aug 27 15:44:33.596 PST: ISDN Se1/0:23 Q931: Applying typeplan for sw-type 0xD is 0x0 0x1, Called num 15094558770

Aug 27 15:44:33.596 PST: ISDN Se1/0:23 Q931: TX -> SETUP pd = 8 callref = 0x44C4

Bearer Capability i = 0x8090A2

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA98389

Exclusive, Channel 9

Calling Party Number i = 0x0181, '613XXXXXXX'

Plan:ISDN, Type:Unknown

Called Party Number i = 0x81, '15094558770'

Plan:ISDN, Type:Unknown

Aug 27 15:44:33.680 PST: ISDN Se1/0:23 Q931: RX <- CALL_PROC pd = 8 callref = 0xC4C4

Channel ID i = 0xA98389

Exclusive, Channel 9

Aug 27 15:44:33.680 PST: ISDN Se1/0:23 Q931: RX <- PROGRESS pd = 8 callref = 0xC4C4

Cause i = 0x8081 - Unallocated/unassigned number

jbarcena Thu, 08/28/2008 - 13:21

You are sending 11 digits, are you sure that you need to send the first digit to your telco?

Verify with them what you should be sending them. As already stated since the call is hitting the GW the problem is NOT in CCM.

Check with your Telco and then just change in CCM or in the GW what should be send.

learnerkang Thu, 08/28/2008 - 13:14

We tried 509 number on two extensions and got same problem. Users got "we can't complete the call with number you've dialed" after 3 rings.

CSS looks Okay. We are checking the Router Pattern now.

By the way, it should be nothing to do with Translation pattern, right?

shabali52 Thu, 08/28/2008 - 13:18

Do you get "Your call cannot be completed as dialed" or is it a fast busy signal? If you are getting the first message, then it is do with extra/less digits being sent to telco. Usually telco doesnot like the 9 with the number so if your pattern is 9.@, you should do "strip predot" and it should let you dial successfully.

iptuser55 Fri, 08/29/2008 - 05:49

The fact you are seeing the number in the DEBUG Q931 message means you are sending the number as per the debug i.e without the 9 and your CSS are correct as far as the outbound to the GW so all good. There are normally two reason why you get a unassigned number

Inbound to CCM- The CSS of the gateway can not see the partition which called Number is in

Outbound- The Telco does not recognise the number. Is number owned by the Telco, an issue is may they have not updated their switches so do not recognise the number - is it new -I`ve had this between Telco`s in NY

Is the GW directly out to the telco or does it connect to another CCM, PABX?

Actions

This Discussion