Ciscowork LMS discovery hung

Unanswered Question
Aug 28th, 2008

This is an existing LMS installation and I ran device discovery to gather changes since last discovery over 18 months ago. Device discovery has been running for 5 days. The network is only about 110 switches. I cannot stop it running. Have tried rebooting server. I would be happy to clear all databases and start again but how do I do this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Joe Clarke Thu, 08/28/2008 - 22:02

What version of Common Services and Campus Manager do you have?

bronning Thu, 08/28/2008 - 22:53

It's LMS 2.5. Sorry I don't have the components versions because I have left the site. I think CM is 4.0 but I will confirm on Monday.

bronning Sun, 08/31/2008 - 16:09

Products Installed

CW Common Services 3.0

Campus Manager 4.0

CiscoView 6.1

DFM 2.0

IPM 2.6

Integration utility 1.6

RME 4.0

Joe Clarke Sun, 08/31/2008 - 16:20

This is quite old, and had a number of bugs. I recommend you upgrade to the latest available LMS 2.6 SP1 version which will give you Campus Manager 4.0.11 which fixes a number of discovery bugs.

To get to LMS 2.6 SP1 from LMS 2.5, you must first download and install the LMS 2.5.1 update. Then you need to download the 2.6 update. Finally, use Common Services > Software Center > Software Update to download updates for Common Services, RME, Campus Manager, and DFM.

LMS 2.5.1 :

LMS 2.6 :

bronning Sun, 08/31/2008 - 20:43

In installed LMS 2.5.1 then LMS 2.6 updates successfully. Problem downloading other updates...

Got CM update (wouldn't install - requires CWCS)

Tried download CWCS update but now won't go past credentials screen. Tried several times (had to delete psu.lock) but no progress. Just sits there waiting.

ALSO.. and I think this relates to my original problem..

CM Home page says "ANIServer is still initializing" under Status and Discrepancies.

Process status for ANIServer is "running with busy flag set". If I restart then it goes the same after a few seconds.

Any advice?

Joe Clarke Sun, 08/31/2008 - 23:48

Running with busy flag set is the normal state for ANIServer. ANI may take time to fully initialize, so seeing this message on the Campus homepage may just mean you need to wait longer. Typically, it takes around 20 minutes for all of the LMS daemons to fully initialize after starting dmgtd.

To get CS 3.0.6 you may need to download it directly from .


This Discussion