Caller ID (CLID) not being passed from SIP to ISDN

Unanswered Question
Aug 29th, 2008


Hope you can help,

Does anyone know how to ensure that the Callser-ID gets carried from a SIP INVITE message over to a ISDN SETUP message ? From reading cisco papers, it appears that if the "remote-party-id" in the sip-message is populated, then the clid in the isdn-message should be automatically data-filled. But I have tried lots of configurations without any joy.

I am using an AS5350XM with 12.4-6.T3. I see the "remote-party-id" field correctly within the INVITE, but when I debug the ISDN-Q931, I see a blank field. It is not being passed on.

Hope you can help.

Thanks, Matt


INVITE sip:[email protected]:5060 SIP/2.0

Via: SIP/2.0/UDP;branch=z9hG4bK4718D9

Remote-Party-ID: "MATT" <sip:[email protected]>;party=calling;screen=yes;privacy=off


Q931: TX -> SETUP pd = 8 callref = 0x0081

Bearer Capability i = 0x8090A3

Standard = CCITT

Transfer Capability = Speech

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Channel ID i = 0xA9839F

Exclusive, Channel 31

Progress Ind i = 0x8183 - Origination address is non-ISDN

Calling Party Number i = 0x01C3, N/A

Plan:ISDN, Type:Unknown

Called Party Number i = 0x81, '02075177151'

Plan:ISDN, Type:Unknown


Here is the config,



interface Serial1/6:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn supp-service name calling

dial-peer voice 206 pots

destination-pattern .T

port 1/6:D

forward-digits all


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)


This Discussion