UCCX 5.0(2) JTAPI Errors

Unanswered Question
Aug 29th, 2008
User Badges:

Hello Folks.


I've installed a Callmanager 6.1.2 with UCCX 5.0(2) on separate servers, same subnet with UCCX as a Single Node install. I've completed the Express install and setup portion, but upon login to Appadmin, the following Error message populates:


“The Cisco JTAPI Client versions are inconsistent. Please go to Cisco JTAPI Resync in the Unified CM Telephony Subsystem to install the Cisco JTAPI Client.”


From here I go to Subsystems, Unified CM Telephony and run the 'Cisco JTAPI Resync'. After Cisco JTAPI Resync, Error message populates

“Cisco JTAPI Client: An error has occurred while trying to resynchronize the Cisco JTAPI Client. Please try Cisco JTAPI Resync in CRS Administration again.”


The JTAPI versions are the exact same between the Express server and CallManager:

C:\>java CiscoJtapiVersion

Cisco JTAPI version 6.1(2.1000)-12 Release


Until the Express server sees the JTAPI versions as consistent, The CRS Engine -> CM Telephony Subsystem will not go into Service. Does anyone have insight into how I can get this resolved?


-Regards.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.7 (3 ratings)
Loading.
Chad Stachowicz Fri, 08/29/2008 - 22:36
User Badges:
  • Silver, 250 points or more

why dont you just go download the jtapi cleint from the ccm plugin page and install it on the CRS manually. then try again!


Chad

athanp Sat, 08/30/2008 - 03:21
User Badges:

JTAPI Client is installed, whether from CCM Plugins or the as from JTAPI Resync. Regardless, CRS sees the versions as out of sync even though they are the same:


Cisco JTAPI version 6.1(2.1000)-12 Release


This is installed on Vmware on a Non Cisco OS with Registry Hacks. This is a Demo Lab Only. Appreciate any tips on getting around this JTAPI Nightmare.


Chad Stachowicz Sat, 08/30/2008 - 11:24
User Badges:
  • Silver, 250 points or more

Windows 2003 OS for IBM installs in vmware just fine. Thats probably your problem. Either way no one is going to help you with unsupported configurations, thats why its unsupported :)


Chad

mikram Mon, 09/15/2008 - 02:56
User Badges:
  • Bronze, 100 points or more

Hi


1.) I created foleder C:\winnt

2.) I copied folder java from c;\windows into c:\winnt

3.) I tried Resync and it works now fine without disturbing error message.


It should fix the problem.


Cheers

Ikram


athanp Mon, 09/15/2008 - 07:25
User Badges:

Yes, that fixed the issue. Thank you for sharing.


-Regards, Athan


mserwon Mon, 06/18/2012 - 08:41
User Badges:

I also used this with 7.01 CUCM and UCCX and it fixed the issue

Thanks,

Actions

This Discussion