Need help on bridging

Answered Question
Aug 29th, 2008
User Badges:

hi,


In my network i have some switches which is runing Bridigeing instance.. now i am planning to migrate to STP. what precaution in need to take..


connectivity..


COre-- BRIDGE SW(2948) -- PC


sample config of one VLAN in both the switches..


interface BVI64

ip address 172.16.164.3 255.255.255.0

no ip redirects

no ip directed-broadcast

standby 164 priority 100

standby 164 ip 172.16.64.1


interface Vlan164

ip address 172.16.64.2 255.255.254.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip route-cache flow

standby 164 ip 172.16.164.1

standby 164 priority 200

standby 164 preempt


For two they have given two GW for one VLAN..


pls help me out


Regards

sateesh kumar.k



Correct Answer by Giuseppe Larosa about 8 years 10 months ago

Hello Sateesh,

everything is ok


be aware that this switch could be unable to support L3 Vlan this depends on the IOS code on it.

You may need to upgrade it to use the Vlan Syntax and to take advantage of real PVST+.


Hope to help

Giuseppe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Giuseppe Larosa Fri, 08/29/2008 - 11:53
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Sateesh,


BVI are used by IRB = Integrated Routing and Brdiging


you can equate one BVI as one L3 Vlan like Vlan164.

all ports with bridge-group 64 are part of the same L2 VLan broadcast domain


be aware that STP is already running on IRB may be with a standard 802.1D CST version


if you do show spanning-tree on the switches using the BVI you can see it


Hope to help

Giuseppe

sateeshk10 Fri, 08/29/2008 - 12:01
User Badges:

pls find below sh span-tree from BVI..pls chk an d confirm


if so what to do...???


sw#sh spanning-tree


Bridge group 132 is executing the IEEE compatible Spanning Tree protocol

Bridge Identifier has priority 32768, address 0003.9f17.a807

Configured hello time 2, max age 20, forward delay 15

Current root has priority 8192, address 0009.b7ad.e083

Root port is 63 (GigabitEthernet50.132), cost of root path is 4

Topology change flag not set, detected flag not set

Times: hold 1, topology change 35, notification 2

hello 2, max age 20, forward delay 15

Timers: hello 0, topology change 0, notification 0

bridge aging time 300


Port 4 (FastEthernet1) of Bridge group 132 is down

Port path cost 19, Port priority 128

Designated root has priority 8192, address 0009.b7ad.e083

Designated bridge has priority 32768, address 0003.9f17.a807

Designated port is 4, path cost 4

Timers: message age 0, forward delay 0, hold 0

BPDU: sent 0, received 0

Giuseppe Larosa Fri, 08/29/2008 - 12:57
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Sateesk,


just check that the root bridge ID is that of your core switch


Current root has priority 8192, address 0009.b7ad.e083


on interfaces the core switch should revert to IEEE 802.1D instead of using PVST+.


Bridge group 132 is executing the IEEE compatible Spanning Tree protocol

Bridge Identifier has priority 32768, address 0003.9f17.a807

Configured hello time 2, max age 20, forward delay 15

>> Current root has priority 8192, address 0009.b7ad.e083

Root port is 63 (GigabitEthernet50.132), cost of root path is 4

Topology change flag not set, detected flag not set

Times: hold 1, topology change 35, notification 2

hello 2, max age 20, forward delay 15

Timers: hello 0, topology change 0, notification 0

bridge aging time 300


If the core switch is the root bridge and is using 802.1D on the port to the switch using BVIs everything should be fine


Hope to help

Giuseppe

sateeshk10 Fri, 08/29/2008 - 13:05
User Badges:

Hi,


pls find below the my core sw spantree..bUT MAC ADD DIFFRENT..PLS CHK


COreSW#sh spanning-tree


VLAN1 is executing the ieee compatible Spanning Tree protocol

Bridge Identifier has priority 8192, address 0009.b7ad.e000

Configured hello time 2, max age 20, forward delay 15

We are the root of the spanning tree

Topology change flag not set, detected flag not set

thanks

sateesh

Giuseppe Larosa Fri, 08/29/2008 - 13:20
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Sateesh,


address 0009.b7ad.e083

0009.b7ad.e000


vlan 132 without MAC address reduction means a different mac address for each vlan instance.


do a show spanning-tree vlan x on core switch


where x is the vlan that pairs with Bridge-group 132


It should be fine a good news is: "ieee compatible Spanning Tree protocol"


Hope to help

Giuseppe




sateeshk10 Fri, 08/29/2008 - 13:23
User Badges:

Hi ,


your are right..pls find below the same..

pls let me know shall i enable STP on my sw


crsw#sh spanning-tree vlan 132


VLAN132 is executing the ieee compatible Spanning Tree protocol

Bridge Identifier has priority 8192, address 0009.b7ad.e083

Configured hello time 2, max age 20, forward delay 15


Regards

sateesh

sateeshk10 Fri, 08/29/2008 - 13:31
User Badges:

And also my plan that...i will take out this sw from network and reconfigure for STP and i put back into the network...


is it ok..


Regards

sateesh kumar.k

Correct Answer
Giuseppe Larosa Sat, 08/30/2008 - 09:23
User Badges:
  • Super Silver, 17500 points or more
  • Hall of Fame,

    Founding Member

Hello Sateesh,

everything is ok


be aware that this switch could be unable to support L3 Vlan this depends on the IOS code on it.

You may need to upgrade it to use the Vlan Syntax and to take advantage of real PVST+.


Hope to help

Giuseppe

sateeshk10 Sat, 08/30/2008 - 09:32
User Badges:

Hi,


Thanks for your excelent help..


Regards

sateesh kumar.k

Actions

This Discussion