HTTPS error

Unanswered Question
Aug 29th, 2008
User Badges:

Hi, when i try loggin by HTTPS on a router i have next errors.


%HTTPS: http ssl get context fail (-41104)

HTTP: ssl get context failed (-40407)


I have a 2821 router with

c2800nm-advipservicesk9-mz.124-15.T1.bin ios


Can anybody help me?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
garytayl Mon, 09/01/2008 - 05:26
User Badges:
  • Silver, 250 points or more

Try the following:


Router(config)#crypto key zeroize rsa

Router(config)#crypto key generate rsa

How many bits in the modulus [512]: 1024

% Generating 1024 bit RSA keys ...[OK]



garytayl Mon, 09/01/2008 - 05:47
User Badges:
  • Silver, 250 points or more

If you have ip http secure-client-auth in your config, try removing it and then https again.

johnlloyd_13 Mon, 09/01/2008 - 12:07
User Badges:
  • Blue, 1500 points or more

try to add these on your router:

Router(config)#username privilege 15 password <0 or 7>

Router(config)#ip http authentication local

Router(config)#line vty 0 4

Router(config-line)#login local

Router(config-line)#transport input ssh


privilege 15 allows you to configure your router. also, check if you IOS supports crypto functionality

johnlloyd_13 Mon, 09/01/2008 - 12:09
User Badges:
  • Blue, 1500 points or more

i forgot to add this:


Router(config)#ip http secure-server


this command enables https access on the router

A.Timoshenko Mon, 09/01/2008 - 23:20
User Badges:

ssh 1.5 work correct.

of course i know about "ip http secure-server" command.

eng.malak Sat, 10/20/2012 - 14:25
User Badges:

i know this is very old topic but any lick to solve it ?

locbus123 Mon, 12/03/2012 - 13:29
User Badges:

hi,


the solution is easy and gave it above:


Router(config)#crypto key zeroize rsa

Router(config)#crypto key generate rsa

How many bits in the modulus [512]: 1024

% Generating 1024 bit RSA keys ...[OK]


you have to generate key but 1024 not 512 this one is to SSH1.5.... i checked it a few minutes ago

matthias.motte Wed, 01/11/2017 - 01:51
User Badges:

Hi,


I have this problem too.

To fix it I do the folowing :

(conf)#crypto key zeroize rsa

(conf)#ip http secure-server


Try again my connexion to ssl server and ... it's work like a charm ;)


After I create a new rsa key (1024)

(conf)#crypto key generate rsa modul 1024


Try ssh and https, work together now ;)

Actions

This Discussion